My connection has become extremely slow after I updated to 17.04. It was fine in 16.10.

Chrome gets stuck at "Resolving host..." for sometimes more than 30 seconds. I've tried other browsers and they are the same. Meanwhile my phone which is connected to the same network is fast as usual.

I have tried adding following lines to /etc/NetworkManager/NetworkManager.conf but it didn't change anything:

  • 1
    For what it's worth I also have this problem. My wifi connection is unbearably slow, but the problem persists even when wired. This is a brand new install of 17.04, so it shouldn't be an upgrade problem. Apr 16, 2017 at 0:55
  • @MarkRoberts I think I have found a workaround. Go to network settings. Under IPv4 tab, pick the second option as Method and enter a static DNS address. Also check Require IPv4 for this connection to complete if it doesn't work. I tried with Google DNS ( and it seems OK for now. Apr 16, 2017 at 16:40
  • Maybe related to this? bugs.launchpad.net/ubuntu/+source/systemd/+bug/1656830 Apr 18, 2017 at 1:31
  • Could you please edit your question to include the output of the terminal command lspci -nnk | grep -A2 Network? Thanks. May 14, 2017 at 18:31
  • 1
    @DavidFoerster Hi, I think the issue was solved with an update. At least for me. May 15, 2017 at 13:23

5 Answers 5


I had the exact same issue (just like @Mark Roberts).

Here is the fix:

Note: the current /etc/resolv.conf file is actually a symlink to ../run/resolvconf/resolv.conf which appears to be the core issue since it is not maintained by systemd-resolved.

Thus if you do an ls -la you'll see:

~# ls -la /etc/resolv.conf
lrwxrwxrwx 1 root 29 Apr 14 11:36 /etc/resolv.conf -> ../run/resolvconf/resolv.conf

so... to get around this do the following:

sudo rm -f /etc/resolv.conf
sudo ln -s /run/systemd/resolve/resolv.conf /etc/resolv.conf

After that I kicked systemd-resolved just to make sure:

sudo systemctl restart systemd-resolved

This appears to work great because:

systemd-resolved maintains the /run/systemd/resolve/resolv.conf file for compatibility with traditional Linux programs. This file may be symlinked from /etc/resolv.conf and is always kept up-to-date, containing information about all known DNS servers.

Which I quoted DIRECTLY from the bug report:(bug # 1624320) and I believe it is the culprit.


I found this discussion which blames systemd-resolv (something to do with DNS) and suggests the workaround of setting DNSSEC=off in resolved.conf

The exact same workaround has just been released to the Zesty repositories: https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1682499

So long story short: Run Software Updater right now. Maybe that will solve the issue...

  • 3
    Doesn't anyone test it before the release? This is the most obvious bug I've ever seen. Apr 22, 2017 at 11:02

I found a fix for this!

I realized that this issue was originating from a service called ‘systemd-resolved’. This is a DNS caching and validating service that comes pre-installed with Ubuntu 17.04.

The complete Solution is in this article (half way down is the updated version)

Here are my simple notes for the commands (perhaps helpful but the above website does a great job)

service NetworkManager status
head /etc/resolv.conf
sudo nano /etc/resolv.conf

change nameserver to nameserver

sudo apt-get install unbound

Now let’s disable the troublesome systemd-resolved

sudo systemctl disable systemd-resolved
sudo systemctl stop systemd-resolved
sudo nano /etc/NetworkManager/NetworkManager.conf

Change to dns=unbound

sudo systemctl enable unbound-resolvconf
service NetworkManager status

In 17.10, it should not be off in resolved.conf:


Just setting it to no solves it.


It is in the file by default but commented out (with a leading #).


I never had problems with Ubuntu GNOME 16.04 LTS but tried Ubuntu 17.04 and adding gnome-session, and that's when problems started. I was hoping to move to Ubuntu and enjoy Ubuntu Upgrade to 17.10 with Gnome DM, but alas:

  • Spotty wifi
  • Slow Internet (Wired and WiFi)
  • Apps installing at 60-90% ... not finishing for 10's of minutes! or not at all

My solution after trying many workarounds was to install a fresh Ubuntu GNOME 17.04.

And how do I know that LightDM was the culprit? Well, in my frustration at video tearing, someone suggested LightDM is much better (for the moment - a vsync issue) so I installed it. I logged back in with LightDM and... yep, ridiculous internet issues.

Not the answer you're looking for? Browse other questions tagged or ask your own question.