This question already has an answer here:

I upgraded from 16.10 to 17.04 and my laptop connects to home wifi but acts as if the network is not working, no website would load. It's not the browser, none of the apps work. A dozen reboots of laptop and router did nothing. Other laptops (win7), phones and tv use this network without issues. All was fine this morning but then the home wifi just stopped working on ubuntu (after waking it from sleep). For a few minutes it worked fine connected to the extender of that home wifi but then stopped that too. Ubuntu connects and uses my mobile hotspot without issues, so far. Any ideas? None of the fixes in previously asked similar questions worked for me so I was told in another thread to ask my own question.

marked as duplicate by Elder Geek, Eric Carvalho, Fabby, Organic Marble, 2707974 Apr 19 '17 at 6:40

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • try forgetting the network than reconnecting? – Jonluke Biddle Apr 15 '17 at 23:07
  • try this may be it will work : sudo service network-manager restart – gunjan parashar Apr 16 '17 at 15:10
  • I tried both of those several times before posting the question here, didn't work. – Shaolinka Apr 17 '17 at 10:09
  • Check out this answer:… – Jay Apr 17 '17 at 11:04
  • 1
    The DNS change that you accepted below is the same what multiple answers to the linked question suggest. I'm voting to keep this question closed. – David Foerster Apr 20 '17 at 10:00
up vote 7 down vote accepted

Try this: (solved my problem with DNS)

  1. Right click on Wi-Fi icon at the top-right corner of the screen
  2. go to "Edit Connections..."
  3. Mark your wifi network
  4. click "Edit" button
  5. Open "IPv4 Settings" tab
  6. Choose method: "Automatic (DHCP) addresses only"
  7. Copy&Paste, to "DNS servers"
  8. Save
  9. Reboot PC
  • This worked (editing connection)! Hopefully it sticks because the other fixes I tried only worked until the next reboot or wake up. Thanks! – Shaolinka Apr 17 '17 at 10:57
  • This is bug report that concerns many users of 17.04. Note that the problem affects both wifi & ethernet, some of the other reports are wifi or usb wifi only. – doug Apr 18 '17 at 0:45
  • I believe that you can mark this as solution to your problem with that green sign. – user140345 Apr 18 '17 at 10:46
  • 1
    Tried this and it hasn't work. I'm I missing something. What is potentially causing this issue? – Rudy Jessop Jul 23 '17 at 3:09
  • This is not the solution to my problem. I already do this and I still experience random dropouts especially at critical times. It's frustrating. – rvdavid Sep 15 '17 at 3:00

Here is a link of the bug.

And here is what you should try:

Open a terminal and type or paste this and run it:

sudo -H gedit /etc/NetworkManager/NetworkManager.conf

Then edit the file and add these lines to the bottom of the file:


Save the file and run this command in a terminal:

sudo service network-manager restart
  • 2
    I believe this issue that you give the fix for prevents you from connecting to wifi at all. The OP says he can connect to wifi, but not the internet. Ergo, DNS problem. – Organic Marble Apr 19 '17 at 0:56
  • If that is the case, the OP should try running this command in a terminal: sudo killall dnsmasq – Provided Apr 20 '17 at 1:19
  • On reboot, the wifi doesn't even connect anymore, when I removed the inserted line in NetworkManager.confand reboot I get a wifi connection but no internet. – Rudy Jessop Jul 23 '17 at 3:11
  • Even if this didn't answer OP's question, it fixed an issue for me. – Caustic Aug 16 '17 at 12:37

AIP (Answer in Progress)

Wild guess, have you tried changing your DNS?

sudo -H gedit /etc/resolv.conf 

change nameserver to nameserver, save & close.

  • 1
    No no no. You don't manually edit /etc/resolv.conf. It even says so RIGHT IN THE FILE. – heynnema Apr 16 '17 at 15:09
  • because it will get rewritten on the next boot up, but we only need to see if this works – user140345 Apr 16 '17 at 20:37
  • To get clarification from the OP, it's customary to drop a comment which you have the reputation to do (so far) – Elder Geek Apr 17 '17 at 15:23
  • THIS HAS FINALLY solved my issue in my Starbucks coffee wifi shop .... how to make it permanent? – napi15 Jan 10 at 20:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.