7

I recently upgraded from Ubuntu 16.10 to 17.04. In Ubuntu 16.10, I could setup a WiFi hot-spot to give Internet access to my Android phone using the trick mentioned in this article Share internet with Android Ubuntu 14.04. I can connect to WiFi now using the fix mentioned in answer to this question: Can't connect to wifi on Ubuntu 17.04.

But when I click on "Connect to Hidden WiFi Network" and choose to start the hot-spot setup, I see this notification and it doesn't start.

Wireless Disconnected

How should I resolve this?

1

2 Answers 2

5

I hope this article can help with your problem.

How to Overcome Ubuntu 17.04 Failed to Make Wifi Hotspot

  1. If Hotspot is on then turn it off first. Go to System Settings > Network

    Turn off Hotspot by clicking ON so it becomes OFF

    Click Stop Hotspot

  2. Click All Settings > Software and Updates

    Make sure the settings shown are checked.

    enter image description here

  3. Click the Close button and let Ubuntu 17.04 update after entering the password. Wait for it to finish. Click Reload.

  4. Press Ctrl+Alt+T to start the Terminal application.

  5. Type the following command in Terminal:

    sudo apt install hostapd dnsmasq
    
  6. Go back to the Network window and click Use as Hotspot then click Turn On.

    Hotspot is ON with the name HP-EliteBook-2760p (on my computer)

  7. In order for Android devices to be able to connect to this Hotspot, there is still one more step, namely:

    Click Edit Connections

    Select Hotspot then click Edit

    Change Mode to Hotspot (provided Ad-hoc)

    Click Save

    Click Enable Wi-Fi to disable your Wi-Fi

    Click again Enable Wi-Fi to enable Wi-Fi

And…. Alhamdulillah ... now Hotspot on Ubuntu 17.04 can function normally. Android devices can also connect.

1
  • 1
    Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – Elder Geek
    Apr 23, 2017 at 17:55
0

OK. To fix the problem, just install hostapd and dnsmasq from repository.

Type on terminal:

Sudo apt install hostapd dnsmasq

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.