1

I have Windows 10 and Ubuntu 16.04 LTS installed in seperate partitions. I followed a tutorial on how to restore grub after installing Windows. Grub did install, I could boot into Ubuntu, however, it didn't recognize Windows. I could boot into Windows through F12 menu, however, booting into Windows deleted grub. Then I found out I should disable the "fast boot" option of Windows to prevent it from hibernating and allow grub to recognize it. Now grub did recognize Windows, however, it seems that Windows messes it up. I boot into Ubuntu, all works fine. Than I boot into "Windows Boot Manager" option in grub. It boots into Windows. After shutting down computer and turning it on again, it now boots into Windows without opening GRUB. However, if I place Ubuntu live USB in, enter try Ubuntu mode and than shut down(without doing any further action), after reboot it again opens grub menu. Thus I understand that grub isn't deleted by Windows. However, Windows does something to prevent grub from showing up at the start of boot(propably enables "Windows Boot Manager" as default boot option and hides grub?). I want to know how to fix this option and make me able to boot into Ubuntu without having to use live USB now.

5
  • maybe your startup delay is set to 0
    – Greg
    Apr 15, 2017 at 17:19
  • What brand/model system? Some brands use description as part of UEFI boot entry and make "Windows Boot Manager" as only default. YOu should be able to boot with f12. Sony, HP & others: askubuntu.com/questions/486752/… Boot-Repair should automatically do copy file with 'use standard EFI file': askubuntu.com/questions/582073/dual-boot-but-only-windows-boots/…
    – oldfred
    Apr 15, 2017 at 18:11
  • I have Lenovo IdeaPad Y700. I will check the links;) Apr 15, 2017 at 21:24
  • OK! Checked them, but I'm not really willing to do all that stuff. It seems that F12 actually leads me to a menu where I can select ubuntu(grub) as bootloader during boot so I can boot into Ubuntu. It partially solves issue, but yet it's not simple as I have to get right timing for the F12... Apr 15, 2017 at 22:07
  • "After shutting down computer and turning it on again, it now boots into Windows without opening GRUB." --> I had a similar issue: "restart" from W10 would make grub menu disappear, solved it by putting the Ubuntu SSD as the first boot option in the BIOS/UEFI (was W10 SSD).
    – Blupon
    Dec 28, 2021 at 14:22

1 Answer 1

1

It looks like I found a working solution.

Installing boot-repair(https://help.ubuntu.com/community/Boot-Repair) and running recommended repair adds a working boot entry for Windows in grub. Selecting this entry does not break grub, allowing to boot into Linux afterwards.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .