0

I just installed Xubuntu 17.04 with me folder from old version of xubuntu. And when I connected to Access point (DHCP) it work few times when I visit some web pages but then I got error:

DNS_PROBE_FINISHED_BAD_CONFIG

my /etc/resolv.conf looks like this:

nameserver 127.0.0.53

I've fixed the issue by hard coding the nameserver to 8.8.8.8 (google dns I think) and it's working but why the nameserver is my localhost? I've try to change connection to address only and add DNS servers in connection in network manger but the nameserver in resolve.conf is still my localhost, why? I probably will need to remove symlink and make real file with nameserver, but I want to know if there is better (simpler) solution for the issue I'm having and also why the nameserver is my localhost?

UPDATE I've just deleted resolv.conf symlink with a file with hard coded nameserver but after reboot I've again get symlink (but to different file) but now with localhost 127.0.1.1 as nameserver. Anybody know how to make it permanent?

UPDATE: when I call systemd-resolve --status I've got this in return:

Link 3 (wlp2s0)
      Current Scopes: DNS LLMNR/IPv4 LLMNR/IPv6
       LLMNR setting: yes
MulticastDNS setting: no
      DNSSEC setting: allow-downgrade
    DNSSEC supported: yes
         DNS Servers: 23.253.163.53
                      fe80::1

the DNS is there, maybe it's because when it reconnect the wifi. I have this in dmesg:

[43800.343513] wlp2s0: AP 64:3e:8c:66:cb:e4 tries to chanswitch to same channel, ignore
[43800.343519] wlp2s0: cannot understand ECSA IE operating class 12, disconnecting

I've also try to put this in /etc/dhcp/dhclient.conf:

interface "wlp2s0" {
  supersede domain-name-servers 8.8.8.8, 8.8.4.4;
}

after this I've got more dns servers in systemd-resolve --status but when it reconnect (probably) then I've got the DNS error.

  • @Fabby I already seen this question, my is different I got this when the symlink was correct and I didn't get the error when run resolvconf -u – jcubic Apr 18 '17 at 12:58
  • Close vote retracted. – Fabby Apr 18 '17 at 20:27
1

First... DON'T manually edit /etc/resolv.conf... it says so right in the file... 'cause your manual edits WILL get overwritten. Also, DON'T start deleting symlinks/etc if you don't know what they do.

The proper way to add DNS servers is to edit your connection profile. Go to the IPv4 Settings tab, change the popup to "Automatic (DHCP) addresses only", and place your DNS servers in a comma-separated list where it says "DNS Servers".

enter image description here

Update #1 - from DNS_PROBE_FINISHED_BAD_CONFIG error in Ubuntu 14.04 with corrections

In terminal...

sudo rm -i /etc/resolv.conf
sudo ln -s /run/resolvconf/resolv.conf /etc/resolv.conf
sudo resolvconf -u
  • I've already try that and I still get the local server as the only nameserver in resolv.conf – jcubic Apr 15 '17 at 19:59
  • What do you get in terminal when you type ps auxc | grep dns? – heynnema Apr 15 '17 at 20:04
  • kuba 4114 0.0 0.0 72208 7068 ? Sl 22:00 0:00 gvfsd-dnssd – jcubic Apr 15 '17 at 20:05
  • How about grep -i dns /etc/NetworkManager/NetworkManager.conf? – heynnema Apr 15 '17 at 20:07
  • got nothing in return – jcubic Apr 15 '17 at 20:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.