1

I bought a new Asus R510V laptop and after installing Ubuntu 16.04, I found out that whenever I pull the power cable out of the laptop, if I wait 4-5 minutes it freezes completely. I'm going to tell you about my machine and about what I've already tried.

  • The laptop has an Intel i7-6700HQ 3.5ghz, nvidia Geforce 950m, 8gb ram, 256gb ssd.
  • I use nvidia-375.39 proprietary drivers that they recommended on their website. I've also tried with 378 (which they list as beta) and it didn't work. 378 was open source though.
  • I'm using kernel version 4.8.0
  • This problem happens both on wired connection and wireless.
  • Someone said that my disk may be corrupted. I booted from grub into safemode and typed sudo fsck -f /. It didn't throw any errors, only "Passed 1, Passed 2...". So I guess that is not the problem
  • When the laptop freezes, alt+sysrq+REISUB doesn't work. Even after enabling sysrq commands explicitly. The commands do work when the laptop behaves normally, they just don't seem to do anything when it freezes.
  • Some people said to turn off power management with sudo iwconfig wlan0 power off. They are always wlp2s0 instead of wlan0, but even so, sudo iwconfig wlp2s0 power off doesn't work. Nevertheless, for me, iwconfig shows Power Management:off both for wired and wireless connections
  • I created the file /etc/pm/config.d/blacklist and placed HOOK_BLACKLIST="wireless" in it. It doesn't have any effect both on wireless and wired.
  • If I close the lid after freeze, it does not suspend.
  • After it freezes, it waits ~10 seconds and then the fan/cooler (I think) starts blowing loudly on the left side.
  • Sometimes, when I try to boot into safemode, I can see that there are some serious visual bugs. I can still type normally, but the screen messes up when I move the selection to choose "root" and debug my system in safe mode. Again, only sometimes. That is why I think it's related to the graphics driver.
  • I've heard that some older Linux kernels had bugs with HQ6700, maybe it's related to this? If yes, which version do I need?

Although my laptop is not a Zenbook, I followed the instructions here (first thing after table of contents): https://help.ubuntu.com/community/AsusZenbook

I added those extra parameters to GRUB_CMDLINE_LINUX, I installed tlp and tweaked those options to the values they recommended, I shut the device down, removed the battery (mine is detachable), waited for a couple of minutes, booted into ubuntu and the problem persisted.

Currently, this is what I have in /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_pstate=disable pcie_aspm=force acpi_osi='Windows 2009' acpi_os_name='Windows 2009' intel_idle.max_cstate=1 acpi_backlight=vendor"
GRUB_CMDLINE_LINUX="intel_pstate=disable pcie_aspm=force acpi_osi='Windows 2009' acpi_os_name='Windows 2009' intel_idle.max_cstate=1 acpi_backlight=vendor"

In the past, I've also tried with this but it didn't work either:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_idle.max_cstate=1 acpi_backlight=vendor acpi_osi='!Windows 2013' acpi_osi='!Windows 2012'"

Yes, I did run update-grub.

This is what I added to /etc/default/tlp after installing tlp:

CPU_SCALING_GOVERNOR_ON_BAT=ondemand
CPU_BOOST_ON_BAT=0
PCIE_ASPM_ON_BAT=powersave
RUNTIME_PM_ON_BAT=on 

I've also found these, which did not solve my issue:

Ubuntu (15.10, 16.04, 16.10) freezes on resume from suspend (only on battery)

New Asus laptop freezes every couple of minutes when on battery

Thank you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.