3

When I open a terminal, I get:

line 106 unexpected EOF while looking for matching `''
line 120 syntax error: unexpected end of file

bashrc has

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
case $- in
*i*) ;;
  *) return;;
esac

# don't put duplicate lines or lines starting with space in the history.
# See bash(1) for more options
HISTCONTROL=ignoreboth

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# If set, the pattern "**" used in a pathname expansion context will
# match all files and zero or more directories and subdirectories.
#shopt -s globstar

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt 
below)
if [ -z "${debian_chroot:-}" ] && [ -r /etc/debian_chroot ]; then
debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
xterm-color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; 
turned
# off by default to not distract the user: the focus in a terminal 
window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
# We have color support; assume it's compliant with Ecma-48
# (ISO/IEC-6429). (Lack of such support is extremely rare, and such
# a case would tend to support setf rather than setaf.)
color_prompt=yes
else
color_prompt=
fi
fi

if [ "$color_prompt" = yes ]; then
PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\
[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
 PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
;;
*)
;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval 
"$(dircolors -b)"
alias ls='ls --color=auto'
#alias dir='dir --color=auto'
#alias vdir='vdir --color=auto'

alias grep='grep --color=auto'
alias fgrep='fgrep --color=auto'
alias egrep='egrep --color=auto'
fi

# some more ls aliases
alias ll='ls -alF
alias la='ls -A'
alias l='ls -CF'

# Add an "alert" alias for long running commands.  Use like so:
#   sleep 10; alert
alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo 
terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-
9]\+\s*//;s/[;&|]\s*alert$//'\'')"'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
. ~/.bash_aliases
fi

# enable programmable completion features (you don't need to enable
#line 106 this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if ! shopt -oq posix; then
if [ -f /usr/share/bash-completion/bash_completion ]; then
. /usr/share/bash-completion/bash_completion
elif [ -f /etc/bash_completion ]; then
. /etc/bash_completion
fi
fi

JAVA_HOME=/usr/lib/jvm/java-7-openjdk-amd64
export JAVA_HOME
PATH=$PATH:$JAVA_HOME/bin
export PATH

There is no line 120! The last line I have is 119 . I tried to figure out where the problem was but I couldn't find anything.

  • Are those `s remnants from formatting? – heemayl Apr 15 '17 at 13:41
  • sorry , I deleted it – user3188912 Apr 15 '17 at 13:43
  • 1
    Ok, please add your full ~/.bashrc – heemayl Apr 15 '17 at 13:44
  • 1
    What is the line 106 # this, if it's already enabled in /etc/bash.bashrc and /etc/profile line? Is that actually in your file? Do you have the words line 106 there as you show? – terdon Apr 15 '17 at 13:46
  • 2
    For those types of error you may use shellcheck.net Copy and paste your code and it points you directly to those errors (beside a lot of improvement tipps). – ULick Apr 15 '17 at 17:32
9

Your problem is line 93:

alias ll='ls -alF

You're missing the closing quote ('). That should be:

alias ll='ls -alF'

The error you are getting is confusing because bash sees the opening ' and then tries to find a closing one, and that confuses its parser completely. Just fix the missing ' there and you should be fine.

It is complaining about line 120 because it searches all the way to the end of the file (so last line + 1) and doesn't find its closing quote.

  • yes, that's right . thanks, really i'm on this problem for a week searching ! – user3188912 Apr 15 '17 at 14:08
  • 1
    This and the coloring helps in pinpointing the problem – Rinzwind Apr 15 '17 at 14:08
  • @Rinzwind yeah, since the OP hadn't tagged with bash, there was no coloring. – terdon Apr 15 '17 at 14:10
0

If real reason is not able to found for this error, then better to copy the original .bashrc from /etc/skel/.bashrc and do the updates carefully one by one.

cp /etc/skel/.bashrc ~/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.