7

I'm using a lenovo Y 700 laptop, running Ubuntu 16.04 and I'm trying to fix some graphics issues. One of the problems I'm encountering is, when I select the NVIDIA binary driver in the Additional Drivers tab, wait until the installation finished and reboot, it seems the drivers are not being used.

I know that it is not the mainly selected graphics card (I'm trying to select the NVIDIA card as the main graphics adapter to be in use) and the output of lspci -k | grep -EA2 'VGA|3D' is this:

00:02.0 VGA compatible controller: Intel Corporation Skylake Integrated Graphics (rev 06)
    Subsystem: Lenovo Skylake Integrated Graphics
    Kernel driver in use: i915_bpo
--
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 960M] (rev a2)
    Subsystem: Lenovo GM107M [GeForce GTX 960M]
    Kernel driver in use: nouveau

So, I want to know if the nouveau drivers are in use for the NVIDIA card or the NVIDIA drivers?

  • Please post the exact driver version you tried to install. And again, disable Secure Boot at UEFI settings. Double check if you must beacuse otherwise there's something seriously wrong here. – user589808 Apr 15 '17 at 12:39
  • nvidia binary driver - version 381.09 secure boot is disabled – bartolo 05 Apr 15 '17 at 12:55
  • @CelticWarrior , what could be the source of this problem – bartolo 05 Apr 15 '17 at 13:32
  • Nothing else to suggest. – user589808 Apr 15 '17 at 13:33
9
+50

To answer your question first, you are using the open source nouveau and not the NVIDIA drivers. This means that your attempt to install the proprietary NVIDIA drivers failed for whatever reason. If you want to use the NVIDIA drivers - use a different method from how you tried it by using the GUI.

First completely uninstall the NVIDIA drivers which you have tried to install in your attempt before.

Start the laptop, mark the Ubuntu entry in the GRUB boot menu and then press the E key.
Add nouveau.modeset=0 at the end of the linux line. Press the F10 key to boot the system.
Do not miss to set a Space between the last letter in the linux line and nouveau.modeset=0.

When the login screen appears press Ctrl+Alt+F1. Enter user name and password - execute :

sudo apt purge nvidia*
sudo reboot  

Now install the latest stable NVIDIA drivers 378.13 and nvidia-primefrom the GPU Drivers PPA.

After the restart mark the Ubuntu entry in the GRUB boot menu again and press the E key.
Add nouveau.modeset=0 at the end of the linux line. Press the F10 key to boot the system.
Do not miss to set a Space between the last letter in the linux line and nouveau.modeset=0.

When the login screen appears press Ctrl+Alt+F1. Enter user name and password - execute :

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update
sudo apt install nvidia-378 nvidia-prime
sudo reboot  

Execute lspci -k | grep -EA2 'VGA|3D' ... now you'd see : Kernel driver in use: nvidia

In case you still have problems to get the NVIDIA drivers working, you should consider to opt-in to the Ubuntu LTS enablement stacks, which provide newer kernel and X support for existing Ubuntu LTS releases. This could generally be a good idea, because you are having a quite new notebook. Opt-in to the Ubuntu 16.04 LTS - HWE - enablement stacks by executing the following command :

sudo apt install --install-recommends linux-generic-hwe-16.04 xserver-xorg-hwe-16.04  
sudo reboot  

Before you perform it, remove all NVIDIA software as described in step 1 and reinstall the drivers as described in step 2 after you have installed the new kernel and rebooted the operating system.

Additional information : Boot into the BIOS to make sure that Secure Boot is disabled and that the NVIDIA graphics chip and NVIDIA Optimus are enabled (in some machines this option is available).

  • i've done everything in step 1 and 2, but my laptop now boots in low graphics mode. running lspci in the tty also says nouveau is still the kernel driver in use. – bartolo 05 Apr 20 '17 at 7:44
  • the only way getting rid of low graphics mode i know consist of reinstalling nvidia, so that did not bring me much further – bartolo 05 Apr 20 '17 at 7:47
  • @bartolo05 Have you read the rest of the answer ? Ubuntu 16.04 LTS shipped with kernel 4.4 - and kernels prior to version 4.8 are known to having some compatibility issues with newer intel processors. Uninstall the currently installed NVIDIA drivers and install kernel 4.8 by opting in to the HWE stacks as described ... then reinstall the NVIDIA drivers. Don't forget to reboot after every step ! Also, please check the BIOS settings. :) – cl-netbox Apr 20 '17 at 11:08
  • that worked! a problem i've been having for months now, finally solved! thanks a lot! – bartolo 05 Apr 20 '17 at 13:21
  • This method doesn't quite work for me... – xuq01 Aug 24 '17 at 0:50

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.