0

My Tint2 was working well until 16.10. After upgrading to 17.04, the maximised windows are not getting resized when tint2 is visible. Tint2 is just displayed over maximised window. my settings are autohide = 1 strut_policy = follow_size

1

This is how autohide works now. The behaviour was changed to improve compatibility with applications which did not handle well repeated resize events when maximized. Now tint2 autohide implements the normal behaviour, as in lxpanel, xfcepanel and all others. Even the windows taskbar works like this. Tint2 had the odd behaviour, and there were applications that did not expect it and did not work well with it.

Normally I try to avoid behavioural changes, or changes that break backwards compatibility with older configurations, but in this case this was the only solution that was realistic.

On top of this, it is much faster. Before, it was slow if there were many windows open, or if resizing was computationally heavy, as in VirtualBox windows for example, or games. Some users complained about it. But now showing the panel is practically instant.

If you want tint2 to always "push" the maximized windows, you can disable autohide.

1
  • @o9000it is really sad to see the good features in (Ubuntu) is disappearing day by day :( I think, if there is an additional option to enable resizing, it would be better. – dhiya Apr 17 '17 at 12:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.