11

I'm trying to install Powershell in Ubuntu 17.04 as the following these steps:

curl https://packages.microsoft.com/keys/microsoft.asc | sudo apt-key add -

curl https://packages.microsoft.com/config/ubuntu/16.04/prod.list | sudo tee /etc/apt/sources.list.d/microsoft.list

sudo apt-get update

sudo apt-get install -y powershell

I know I'm using 16.04 packages/built to install. Unfortunately I couldn't find the the 17.04 one.

And here is what error I've got with sudo apt-get install -y powershell

The following packages have unmet dependencies:  
  powershell : Depends: libicu55 but it is not installable 

Then I tried:

apt-cache search libicu

I couldn't find out the libicu55 to install either. Are there any way to install Powershell in Ubuntu 17.04?

  • You should probably wait for MS to release packages for 17.04 – muru Apr 15 '17 at 8:32
  • I really don't wanna down vote your question!. But you are talking 2 different things here. PS is PS, Terminal is Terminal most of the time you can do on both. But for some specific tasks, ofc you can't. For example: if you wanna do LDAP query to AD Server, PS has it own API (modules) to do it ( Ad cmdlets) and also there is possibility to combine PS with .NET, you might be able to do it in Terminal but this is pain is the azz. Generally, they are serving for different approaches :) – Ender Aug 17 '17 at 8:53
9

Download the AppImage version and follow the instructions:

Using a recent Linux distribution, download the AppImage PowerShell-6.0.0-alpha.18-x86_64.AppImage from the releases page onto the Linux machine.

Then execute the following in the terminal:

chmod a+x PowerShell-6.0.0-beta.5-x86_64.AppImage
./PowerShell-6.0.0-beta.5-x86_64.AppImage

The AppImage lets you run PowerShell without installing it. It is a portable application that bundles PowerShell and its dependencies (including .NET Core's system dependencies) into one cohesive package. This package works independently of the user's Linux distribution, and is a single binary.

9

Download libicu55 package from http://packages.ubuntu.com/en/xenial/amd64/libicu55/download

wget http://security.ubuntu.com/ubuntu/pool/main/i/icu/libicu55_55.1-7ubuntu0.4_amd64.deb
sudo apt install ./libicu55_55.1-7ubuntu0.4_amd64.deb

Then follow instructions for 16.04

...
sudo apt install -y powershell

Source: https://asknicks.blogspot.ru/2017/05/install-powershell-on-ubuntu-17.html

2

Microsoft do not have packages for 17.04 yet. Take a look at their github:

enter image description here

The problem you have is their package relies on libicu55, but 17.04 does not have that package in its repositories. Unless you build from source, you will not be able to install their public Powershell packages.

  • 1
    The AppImage from this list will run on most Linux systems including Ubuntu 17.04. To find out more about how this works, visit appimage.org. – probono Apr 15 '17 at 18:29
  • That's a really interesting way of running it, which I didn't know existed before. Thanks for raising it. – Foxie Apr 15 '17 at 18:44
0

Visit the official Microsoft PowerShell Documentation webpage and click the link to visit PowerShell on GitHub or visit it directly. There you will find links to download PowerShell .deb files for Ubuntu 14.04, 16.04 and 17.04.

Download the PowerShell .deb file and double-click it to open it in the software application.


IMG:  Ubuntu 14.04 and later

PowerShell can be installed as a snap package in all currently supported versions of Ubuntu. To install the PowerShell Core snap package open the terminal and type:

sudo snap install powershell --classic  

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.