0

I tried to install redmine 3.2.2 (latest Ver.) on ubuntu 16.04 server with nginx. Then I met some errors to install redmine. Would someone help me to resolve this problem?

Setting up redmine (3.2.1-2) ...
Determining localhost credentials from /etc/mysql/debian.cnf: succeeded.
Bundler could not find compatible versions for gem "railties":
  In Gemfile:
    actionpack-xml_parser was resolved to 2.0.0, which depends on
      railties (~> 5.x)

    jquery-rails (~> 4.0) was resolved to 4.0.0, which depends on
      railties (< 5.0, >= 4.2.0.beta)

    rails (~> 4.2.5) was resolved to 4.2.5, which depends on
      railties (= 4.2.5)

    roadie-rails was resolved to 1.1.1, which depends on
      railties (< 5.1, >= 3.0)
dpkg: error processing package redmine (--configure):
 subprocess installed post-installation script returned error exit status 6
Errors were encountered while processing:
 redmine
E: Sub-process /usr/bin/dpkg returned an error code (1)
2
  • 1
    stackoverflow.com/questions/17327953/… <- You should always google your error messages.
    – user589808
    Apr 15 '17 at 4:25
  • Thanks. I already google, but I cant't find how to resolve. But now I could find the way. I looked in redmine install directory to find gemfile but the gemfile for my redmine was in different directory. And I result install bundle there. It would be OK. Anyway, thank you, because your comment was good hint for me!!
    – tonbo
    Apr 15 '17 at 6:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.