1

Today I decided to do a fresh install of everything on my desktop computer. It has been dual-booting windows 10 together with Ubuntu 15.10 for some time now.

I first installed Windows 10 and made sure it was working as I know from previous experiences that Windows should be installed first. Thereafter I installed Ubuntu 17.04. They both share a 120 GB SSD.

After the installation finished the system is unbelievably slow at booting (~2 minutes) and boots straight into the login screen of Ubuntu.

However, for some reason GRUB is not starting as expected and my monitors keep saying No source found right until the Ubuntu login screen appears. I am unable to both enter BIOS and GRUB. I tried ESC, F11 and Shift while booting. I also tried to fix it by installing [Boot-Repair. Output] (http://paste2.org/eamDtaNh) . I also tried uncommenting the #GRUB_HIDDEN_TIMEOUT=0 and add a value.

Hope someone here can help me as I really want both systems back up running.

  • 1
    Metadata kept in Windows cache, refused to mount. Probably slow trying to mount & then failing to mount hibernated Windows. askubuntu.com/questions/843153/… Turning off fast start up in Windows does make it slower. And grub only boots Working Windows, so if hibernated or if it needs chkdsk grub cannot boot Windows. If UEFI you can boot from UEFI boot menu. It also looks like you re-installed in BIOS/MBR mode. Not as fast as UEFI, if your system is UEFI. Also nVidia may need nomodeset or system work better with nVidia driver. – oldfred Apr 14 '17 at 22:25
  • Thanks for your input! However, I can't even enter Windows to turn off fast start up. How do I boot from UEFI Boot Menu? How do I set nomodeset on my nVidia driver? – Chriswidell Apr 15 '17 at 6:24
  • If UEFI you should always be able to direct boot Windows from UEFI boot menu, often f10 or f12 check your manual. If UEFI fast boot (different than Windows fast start up) is on, you may have trouble getting into UEFI. You then can try cold boot. askubuntu.com/questions/652966/… – oldfred Apr 15 '17 at 13:59
  • Didn't work. I have tried most of the keys that I can think off. Problem is that both screens are black right up until the login screen so I can't figure out what is going on. – Chriswidell Apr 15 '17 at 22:02
  • If already to black screen that is too late. You have to use UEFI keys while UEFI is loading configuration. And UEFI fast boot assumes same configuration, so no load time. You then can try Cold boot. Cold boot to get into UEFI or BIOS, remove battery or fwsetup askubuntu.com/questions/652966/… Grub menu may accept key strokes while menu normally would appear. Have pressed down arrow to get to recovery mode when nothing originally showed. – oldfred Apr 15 '17 at 22:22
0

I just encountered the similar scenarios as you. The following script in terminal works for me: My systems: windows10 and ubuntu 17.04

Please try: sudo update-grub sudo grub-install /dev/sda sudo update-grub

also, please be noted that "boot-repair" didn't work and caused grub loss and unable to boot up for my computer.

Hope this works for you.

HW

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.