0

I'm using 16.04 and I can't see my items on my desktop. Doing gsettings set org.gnome.desktop.background show-desktop-icons true in the terminal does nothing and in Dconf show desktop icons is enabled. I know my folder is still on my desktop because cd /home/desktop shows it there. Any ideas?

8
  • Is the file/directory not hidden? Hidden file/directory's name start with a "." . Check if your file/directory/folders name doesnt start with a dot? – Tshilidzi Mudau Apr 14 '17 at 19:37
  • When you run ls, do you see you folder listed? If not, then it is a hidden folder, in which case just remove the dot at the start of the name :) – Tshilidzi Mudau Apr 14 '17 at 19:43
  • Linux is case sensitive therefore Desktop is not the same as desktop. You want the former and it should be under your username. /home/desktop is just a folder named desktop, not your actual desktop folder, and it has nothing to do with your user. – user589808 Apr 14 '17 at 19:43
  • It shows up in ls and it's not a hidden file either. – Hershey Gamer Apr 15 '17 at 18:58
  • @CelticWarrior /home/desktop is my desktop folder, I'm not using xubuntu or any other re-spin I'm using Unity therefor /home/desktop is my actual desktop folder, also there is not /home/Desktop there is only a /home/desktop folder – Hershey Gamer Apr 15 '17 at 19:03
0

One possibility is a little known glitch in 16.04 that produces an effect similar to the issue you describe. This glitch is activated by moving files from a directory that has a hard linked icon on the desktop.

The most common "fix" for this glitch is to simply:

(1) close or minimize all windows [ Alt+F4 to close individually; Ctrl+Super+D to minimize all windows simultaneously ];

(2) press and hold the Super key until your launcher displays numbers atop its icons;

(3) release the Super key

If this particular glitch is responsible, your desktop icons should immediately become visible. NOTE: This is not a permanent resolution but will work the same way every time it is used.

1
  • Please read the new comments under the question. It's the OP's mistake, that's all. – user589808 Apr 15 '17 at 19:29
0

Install gnome-tweak-tool by typing this in a terminal:

sudo apt-get install gnome-tweak-tool

Then you can run gnome-tweak-tool, go to Desktop, and then turn on the switch in the upper right hand corner.

enter image description here

I have this problem when using the Wallpaper feature CompizConfig Setting Manager to control my wallpaper. Turning on the icons in gnome-tweak-tool restores my desktop icons.

1
  • Nope not working. Nice try. – Hershey Gamer Apr 15 '17 at 18:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.