27

I booted Ubuntu 17.04 live on my Fujitsu Amilo Li3710 laptop and I was surprised to see that I couldn't connect to wifi. I tried to connect to my router and my phone as a hotspot but neither work.

I can see wifi networks and when I try to connect it asks for the password, seemingly tries to connect but then it doesn't connect. It gives no visible feedback after failed trials.

Disabling mac filtering and removing the wifi password makes no difference. I tried Ubuntu, Ubuntu Gnome, Ubuintu MATE and Lubuntu, it's the same everywhere.

I have Ubuntu 16.10 and Windows 10 installed on the laptop, they have no problem connecting.

Is there anything I can do? Or is support for my hardware over in the kernel?

36

There's a bug in this version of network-manager (1.4.4) that shipped with the initial release of 17.04. It randomizes the MAC address of a wifi chipset when connecting to a new network for security purposes but the end result is that some wifi devices won't connect or won't stay connected to the network with this feature enabled.

The good news is this is actually really easy to fix! To disable the randomized mac address switching and fix your wifi, you just have to edit a config file.

You can read about how to fix this in the answer here.

  • Thank you very much. I tried this a couple of days ago but forgot to restart networkmanager. Now it works. – Körtepálinka Apr 16 '17 at 21:56
  • 3
    While this link may answer the question, it would be better to include the essential parts of the article here with a link for reference. – anonymous2 May 1 '17 at 12:26
  • Is there any patch released to fix this issue? – Amit Kumar Gupta Jun 4 '17 at 0:43
  • Thanks a lot! Affect me as well, is it going to be fixed in the next network-manager? – tribbloid Jul 9 '17 at 0:59
  • This works fine the first time. After reboot/restart there is still the same issue. – Pithikos Jul 9 '17 at 17:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.