5

The main reason I want to use firefox ESR is to use a proprietary database tool for work that only allows oracle-java based web logins for linux (or a windows only thin client). I also want to use the full version of the outlook web application which only works in firefox. I don't want to run the NPAPI plugins for normal web browsing and email.

I have the repo version of firefox installed and firefox ESR installed in /opt/firefox and linked to /usr/local/firefox-esr

When I run firefox any attempt to run firefox-esr either brings up a window without the NPAPI plugins.

If I try running with the --new-instance or --no-remote options I receive the following error:

Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system.

Regardless which one I start first, I can only open that one, and get the above error if I attempt to sidestep.

What makes this an especially annoying problem is that I often have to respond to emails that I need to access the database to deal with. So either I close and open many windows.

  • What error did the Windows-only thin client give when you attempted to run it in Wine? – Damian Yerrick Sep 6 '17 at 23:52
  • You may also use the profile manager. – neverMind9 Jan 20 '18 at 10:51
2

You need to use -no-remote option, as in firefox -no-remote.

From man firefox:

-no-remote

Don't connect to any other running instances of firefox. Use this if you want to run firefox in an entirely new process. By default, firefox will delegate a command to an already running instance.

You'll also need separate profiles for Firefox and Firefox-esr, which can be created with with firefox -P Profile Manager.

|improve this answer|||||
  • I tried this, it's in my original post. Actually the firefox command line says --no-remote and the manual says -no-remote. I tried both – N8tron Apr 14 '17 at 17:00
  • This is interesting, have you tried creating a different or duplicate profile for the second firefox process? It works as expected here. – mikewhatever Apr 14 '17 at 20:10
  • mikewhatever: that is interesting. What versions are you using? I'm in ubuntu 16.04. firefoxESR 52.0.2 (64bit) and firefox 52.0.02 (64bit). – N8tron Apr 14 '17 at 20:37
  • Okay forget the versioning. Creating a new profile and manually loading them with the firefox -P works. If you want to put that in a solution I'll accept it. – N8tron Apr 14 '17 at 20:42
  • -no-remote, --no-remote and --new-instance did not work for me, but running FF with -P did the trick! So I run firefox-esr -P, created a new profile for my esr and everything seem fine now. – Shautieh Apr 18 '17 at 2:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.