1

I just upgraded to Zesty on my Surface Pro 3. On Yakkety, I had "Scale for menu and title bars" in System Settings > Displays set to 1.5, and the scale was fine. On Zesty, something really strange is happening, and I cant even explain.

Look at the following pictures:

Link to all above images: I can't post more than two links, so here is a link to all the links.

When the scale go past 1.5, the text and window buttons go tiny, and only the unity launcher scales properly. On Yakkety, scale at 1.5 looked like scale at 1.38, just a bit bigger (the way it should be).

How do I change the scaling to how it was in yakkety?

2

You should restate your problem as a question since it's not clear what you expect.

A patch was applied to Unity 7 for the Zesty release that claims to improve automatic scaling on HiDPI displays, but it completely broke HiDPI settings and behavior for me as well. Like you, in Yakkety and earlier releases, I had Unity's display scale factor set to 1.5, and the UI and font scaling was perfect on my 2560x1440 display. After upgrading and rebooting into Zesty my fonts shrank to tiny proportions, and now I have to settle for a scale factor of 1.38 (which is almost below the comfort threshold for my old eyes) because at 1.5 fonts appear much smaller than they do at 1.38, which is obviously broken behavior.

Here's the changelog documenting the offending change in Unity:

https://launchpad.net/ubuntu/+source/unity/7.5.0+17.04.20161130-0ubuntu1

Here's the diff between the prior Unity release and the current, it contains the new (broken) scaling code:

https://launchpadlibrarian.net/295698352/unity_7.5.0+17.04.20161111.1-0ubuntu1_7.5.0+17.04.20161130-0ubuntu1.diff.gz

  • Could you file a bug report? I've actually switched to Linux Mint on my laptop for now so I can't file a bug for unity. See help.ubuntu.com/community/ReportingBugs – superl2 May 21 '17 at 5:21
  • I see little point in filing a bug because Ubuntu has abandoned Unity for GNOME as of the next release, and I'll be switching to GNOME myself. The chances of Canonical devoting resources to fixing such a bug seem slim so I think it'd be a waste of my time. – John Wang May 21 '17 at 19:55
1

I was able to fix my scaling issues by running this script and re-adjusting the scaling factor in Settings -> Displays.

#!/bin/bash
gsettings reset com.ubuntu.user-interface scale-factor
gsettings reset org.gnome.desktop.interface scaling-factor
gsettings reset com.canonical.Unity.Interface text-scale-factor
gsettings reset org.gnome.desktop.interface text-scaling-factor
  • Very cool! It's also possible to get and set the values for these settings (I'm having trouble making mine persist). In addition, there's a describe argument which provides useful semantics information; eg I never understood the weird scaling factors in the 'Displays' settings applet; gsettings describe com.ubuntu.user-interface scale-factor spills the beans... – sxc731 Nov 25 '17 at 16:18

protected by Community Jul 7 '17 at 9:22

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.