12

my hard drive is located in /media/ronin_cunningham/408242E58242DED2 and I want to change the name 408242E58242DED2 to StorageDevice. How would I do this from the terminal?

Thanks.

3
  • 1
    if you want to do this through command, then please update your question with output of lsblk Apr 14 '17 at 3:04
  • or this one askubuntu.com/questions/147319/…
    – Anwar
    Apr 14 '17 at 4:02
  • Unclear if you want to change the partition / file system label, or just change the mountpoint. The answer below sounds like what you want (mountpoint only), though the "duplicate" question changes the label too
    – Xen2050
    Apr 14 '17 at 7:11
30

The easiest way to do this would be to do it with GUI

  • Go to disk app (through Unity Dash or terminal with gnome-disks command)
  • Choose your partition
  • Click the little gear icon Gear icon
  • Select Edit mount options
  • Toggle Automatic Mount Option to Off
  • Edit mount point to /media/ronin_cunningham/StorageDevice

On a side note, this will also enable your partition to be mounted automatically on start up, If you don't want that to happen then make sure to

  • Un-mark Mount at Startup

You'd want to do this if your Bootup times are slow


screenshot of gnome-disk app Theme might not look exactly like this

5
  • @DKBoss should I edit that in my answer? Apr 14 '17 at 4:27
  • That's totally your call! If you feel it may improve your answer, do so. Otherwise, your answer is fine as it is.
    – DK Bose
    Apr 14 '17 at 4:31
  • 3
    This worked, you guys are very helpful to Linux noobs like me, thank you!
    – R_C
    Apr 14 '17 at 5:43
  • Does this require a reboot to take effect? If so is there anything I can manually run to update this without a reboot. (I tried the above and it still gets mounted to the wrong Mount Point, I guess I will try rebooting but I would have preferred it if that weren't required.)
    – Kvothe
    May 14 '20 at 19:43
  • Okay that was not the issue. It still does not work. It is still mounting to the previous default location.
    – Kvothe
    May 14 '20 at 19:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.