I just tried an install of Ubuntu GNOME 17.04 (looks really nice) and have been able to install from command line and Software Install.

However, if I download a .deb file, eg virtualbox or atom editor, the .deb opens in software install, I click Install but nothing happens, not even a flicker. (did not have this issue on 16.04 or 16.10)

Is there a know problem? Is there an alternative way to install a downloaded .deb?


I have had this problem too (I was trying to install logmein hamachi), you should install gdebi package manager. It worked to install debs on my machine. Hope it helps!

  • I read elsewhere that worked but in the mean time found the solution posted below. – klequis Apr 14 '17 at 3:50

I found the solution in this post on Unix & Linux SE

The post has 3 solutions. I used this one:

You can install it using

sudo dpkg -i /path/to/deb/file followed by sudo apt-get install -f

Atom launched and is installed

  • You can (and should) accept you own answer (unless there is a better one, of course ) – guntbert Apr 18 '17 at 18:29

I solved this by logging out, then logging back in under Ubuntu Xorg. After that I was able to install gdebi and synaptic and successfully install programs as expected.

In particular, I downloaded the chrome deb file, opened it with gdebi and had no problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.