1

I have a fresh install of Ubuntu GNOME 17.04. I was not able to connect to the Internet while using a live USB, but decided to install anyway and try to fix the problem later. Unfortunately, I was not able to solve it.

The problem

I can WiFi networks in the Network manager. When I click on the network I wish to connect to, GNOME asks for the password like it usually does, then it says "Connecting" and a little wheel starts spinning but automatically freezes (see picture). After a moment, the word "Connecting" and the wheel disappear and I'm still not connected to the Internet. There is no error message.

gnome network manager is trying to connect

What I tried

  • Upgrading from 16.10 (it works in 16.10, but fails after an upgrade to 17.04)
  • Rebooting
  • Executing echo 'options ath9k nohwcrypt=1' | sudo tee -a /etc/modprobe.d/ath9k.conf
  • Using other WiFi adapters (all the same problem)
  • Using the same live USB on another computer (Internet works)
  • Using WICD (and it works fine)

More information

Important: I tried to connect to the Internet through USB (with my phone) and the same problem occurs. I tries to connect for several seconds, then it fails without errors messages. So it doesn't seem to be about the WiFi adapter.

My WiFi adapter is a TP-Link TL-WN722N. The chipset number is AR9271 (Atheros).

More technical details: http://paste.ubuntu.com/24377365/

  • Welcome to AskUbuntu! Could you please run the network diagnostics and edit your question to include a link to the result? I know it may seem a bit overwhelming for a novice but your info so far is a bit vague and the diagnostics will likely cover all options that may cause your issue. Thanks. – David Foerster Apr 13 '17 at 21:47
3

I've been having similar issues lately in Ubuntu 16.04 running Unity.

To get it to work, I stop, and then start the network-manager service, and it starts working properly again.

First type this in a terminal:

sudo service network-manager stop

And then type this:

sudo service network-manager start

Or you could just do it in one step with the restart option, but I prefer to give it a few seconds just in case it needs a little time to completely shut down.

sudo service network-manager restart
| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.