2

According to the Ubuntu manuals the command gdlib-config exists on Ubuntu 16.10. See also this blog post.

However, if I do

apt-file search gdlib-config

I get no results. I want to install a package that contains gdlib-config. ( This file is required in order to install a given Perl module )

  • I'm not sure exactly what gdlib-config does, but I've worked around similar issues by creating wrapper scripts for pkg-config – steeldriver Apr 13 '17 at 22:16
6

I ran into much the same problem today when I tried to use cpan to install the Perl module GD. It failed because it could not find package gdlib. I found I needed to install libgd-dev

apt-get install libgd-dev

After this I was able to install the GD module and also had /usr/bin/gdlib-config

  • Thank you, your suggest fixed my issue. – GusDeCooL Jul 19 '19 at 4:50
1

If the above did not work for you, you can install libgd by hand[modified for sudo]:

wget https://github.com/libgd/libgd/releases/download/gd-2.2.5/libgd-2.2.5.tar.gz
tar zxvf libgd-2.2.5.tar.gz
cd libgd-2.2.5
./configure 
make
sudo make install
make installcheck

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.