0

I went over to my Ubuntu machine and noticed a blank screen. I ended up having to, after careful diagnosis, force reboot. Everything loaded up like it should, but when I logged in terminal wouldn't open and STAY open. If I click on it, it just opens for a split second and closes.

After rebooting again and doing everything I could think of, I tried opening text to terminal (ctrl+alt+F1) When trying to login, it flashed quickly again, saying a few things so fast I couldn't read them. I tried logging in again to text to terminal and this time I captured it on my iPhone slo mo cam. It said the usual stuff about last login, documentation and blah blah blah.

However, what is unusual is it says, Shell access is disabled and then goes back to (Computer Name) login:. So my question is. How do I get terminal back open and stay open without wiping this computer again?

I say again because the last time this exact thing happened, I was in a rush so I just performed a fresh clean install. However this keeps happening, and I can't do that every time. One other thing though: this computer probably was running a terminal process, one that I didn't finish, when it probably lost power. This was the result of the "blank" screen. I hope someone can help with this mess.

Ubuntu 16.04.2 LTS

0

It sounds like your user's shell has been set to something like /bin/false. If this is the case, here's one way to tell.

If you look in your /etc/passwd file, find the line with your username on it and examine the final argument (The text after the last :) this describes the path to your user's shell.

Typically this is set with the command chsh, but since you can't use the command line, try editing the /etc/passwd file as root and set the shell to /bin/bash

i.e. a line like this:

username:x:1001:1002::/home/username:/bin/false

would become

username:x:1001:1002::/home/username:/bin/bash

Now save the file, logout and log back in.

| improve this answer | |
  • Ok, so how do I edit this without terminal in my back pocket? It is obviously owned by root. sudo, oh how I miss you. – Trent Harris Apr 13 '17 at 18:47
  • If you did see your shell was set to /bin/false I have this suggestion, first, install gksu, if you can't find it in ubuntu software center, then install synaptic, and use synaptic to install gksu Second alt + F2 will let you type a command in, enter gksudo gedit /etc/passwd – Drist Apr 13 '17 at 18:53
  • Alternatively, create a new administrative user with the control panel, it may have shell access enabled. – Drist Apr 13 '17 at 18:56
  • So was it the gksudo or the new user that got you there? – Drist Apr 13 '17 at 20:08
  • gksudo was the easiest! I feel like such an idiot! – Trent Harris Apr 14 '17 at 3:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.