1

I recently bought a French ASUS M32CD computer with a wireless keyboard and mouse. I'm seeing weird issues with the keyboard, that I don't know how to fix. I have observed this issue on Ubuntu 16.04, 16.10 and 17.04 (fresh install and live CD).

The mouse is working fine and the keyboard as well at the BIOS and GRUB level. Once booted into systemd (from encryption passphrase/Login password and Unity), only a few keys are still working: Shift (both), Controls (both), Alt (both), Super/Windows, as well as the volumes keys.

I have tried a test with xinput test-xi2 command. It seems that no other keys gives an interpreted interruption from the Xorg standpoint.

Here is the lsusb output for this given peripheral:

Bus 001 Device 003: ID 0461:4e80 Primax Electronics, Ltd 
[...]

Any idea on how I could investigate this problem further?

Thank you very much

1

2 Answers 2

0

See a driver on https://github.com/y-trudeau/linux_lenovo_ultraslim_plus – it should work even for your device. (Both devices are made by Primax.)

Do not forget to change Vendor ID to 0461 and Product ID to 4e80 (taken from your lsusb).

1
  • I will update the answer once I know a vanilla kernel solution or there is a more native driver. Commented Jul 7, 2017 at 13:11
0

If you tried the Lenovo fix from Jan Molnar's answer and it did not work, you might want to try this modified fix that I made for another Primax (HP brand) wireless keyboard + mouse combo with similar problems:

https://github.com/JohnJohanssonChalmers/hp_wireless_keyboard

I have seen several reports of these types of problems with Primax keyboards that could not be solved with the Lenovo fix. I suspect that my modified fix might also wok for some non-HP keyboards.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .