I just installed Ubuntu 16.04 LTS via Hyper-V. During the setup it asked me some questions regarding my Keyboard layout, however, after the install; my keyboard isn't set right. the | key gives out a weird A with a dot on top and quotes "" give unknown symbols.

How can I fix my keyboard without reinstalling the OS (hopefully?) Please keep in mind I am a newbie so need detailed instructions?


  • Apparently you selected the wrong layout. Why Ubuntu server? You need to familiarize yourself with the plain desktop before anything else.
    – user589808
    Apr 13 '17 at 16:52
  • i just have a command-line to work with? How can I make that possible thru command-line? keep in mind im a newbie? thnx
    – gsb005
    Apr 13 '17 at 16:53
  • Please read again. I haven't noticed you installed server.
    – user589808
    Apr 13 '17 at 16:54
  • Server gives me more options later down the line, that with desktop I might not have, that's why? Is there a way to fix it in the server-os?
    – gsb005
    Apr 13 '17 at 16:56
  • No, completely wrong. There's no significant difference apart from the server not having a desktop (which can be installed as well) and the desktop not having some tools preinstalled (but they can be installed later if needed).
    – user589808
    Apr 13 '17 at 17:02

You can use the following command

sudo dpkg-reconfigure keyboard-configuration

It should give you all the options, and the configuration persist on reboot

  • Excellent this fixed my problem. thanks arturodr. @CelticWarrior, how <bold>hard</bold> was this to answer, rather than going into a debate into why I installed server vs desktop? How hard?
    – gsb005
    Apr 13 '17 at 18:30
  • @gsb005 Apparently you didn't read the duplicate which mentions this and a lot more. BTW, the newbie - arturodr - who answered should instead flag the duplicate. It's not about being easy or hard, it's about the site's policy and (bad) attitude from a Windows "power user" with the usual sense of entitlement and knowledge that doesn't match reality.
    – user589808
    Apr 13 '17 at 19:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.