0

I'm sure this is simple for someone but I have tried for the last 2 days every piece of information from googling and still no joy! So I would really appreciate some help. I'm newish to the world of Linux but enjoying the change.

The Problem

I recently built a Ubuntu headless 16.04.2 LTS server to run Plex with the media living on my Qnap NAS. Following this guide I got things going pretty easily. So created the mounts like this:

mkdir /mnt/Video 
mkdir /mnt/Audio 
mkdir /mnt/Multimedia 
sudo apt-get install cifs-utils

Added the following lines to the /etc/fstab file

//192.168.1.15/Videos /mnt/Videos  cifs  credentials=/etc/samba/credentials,uid=1000,iocharset=utf8  0  0 
//192.168.1.15/Audio /mnt/Audio cifs  credentials=/etc/samba/credentials,uid=1000,iocharset=utf8  0  0 
//192.168.1.15/Multimedia /mnt/Multimedia cifs  credentials=/etc/samba/credentials,uid=1000,iocharset=utf8  0  0 

then ran the mount cmd

sudo mount -a

the shares mount fine, Plex could read the media and build a library.

Then I wanted to enable Camera Upload from my phone and that is when the fun began. Straight up it wouldn't work so I thought simple- change the permissions for the folder on the NAS to rw and bingo should work- Nope.
I can make and remove a folder from CLI but Plex still no rw access. Plex created a user called Plex so I tried to change the owner and permissions to plex using sudo chown -R plex /mnt/Multimedia but I get "changing ownership of '/mnt/Multimedia/files' : Permission denied. Tried sudo chmod 755 -R /mnt/Multimedia and I get the same response..

When I run a

ls -l /mnt/Multimedia

I get

this

I have since tried different mount options with no luck. Tried creating a group and making plex part of that group and apply the group and no luck.

Why is it so hard to change permissions on a network share?

4
  • 1
    Welcome to Askubuntu.com. You should remove the picture of the text output of your command and make it easier for the users to interpret what is happening on your system by providing the actual text. Pictures of the text are not as easy to read as the actual text itself. It's also a waste of resource storing the pictures rather than the actual text itself. Those are just a few of the many reasons for providing actual text you are providing, over pictures of the text. – L. D. James Apr 13 '17 at 11:07
  • this might help you with the issue of mapping usernames between linux, windows and samba shares: askubuntu.com/a/269653/555486 – Phillip -Zyan K Lee- Stockmann Apr 13 '17 at 11:15
  • thanks for the comments guys.. Tried following that link but it made a mess of my permissions and I could even map the folders. I am going to give up on this... I was hoping there was someone with a similar setup that could shed some light. Thanks again –  Aussybob Apr 14 '17 at 12:08
  • It's not possible for chmod to provide the same error mentioned for chown as chmod changes permissions, not ownership. So your question is completely unclear (at least to me). – Elder Geek Feb 4 '18 at 19:06
0

Have a look at this answer: https://unix.stackexchange.com/questions/68079/mount-cifs-network-drive-write-permissions-and-chown

So the solution is to specify user and group ID when mounting.

1
  • could you please add the steps here? – Zanna Feb 4 '18 at 20:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.