16

It's a rather simple problem, but I can't find the solution:

The menu bar in Kate (File, Edit, ...) has disappeared, and I tried looking up in the katerc file. How can I restore it?

26

Had the same problem... and CTRL+M also solved it for me. I never actively hide my menus, so arriving at this solution was not intuitive. No idea what (bug?) caused the sudden disappearance of the menu.

| improve this answer | |
  • setting a keyboard shortcut to something like that is TOO WEIRD. Quickly after reading this answer, I deleted this shortcut. – Berry Tsakala Dec 26 '19 at 13:31
0

I solved the problem by:

  • looking for katerc with find * | grep katerc, and deleted it
  • sudo apt purge kate
  • sudo apt install kate
| improve this answer | |
0

Came across this same bug this week. Unfortunately I had [Ctrl] + [M] mapped to something else. My solution was to find the file .katerc (in ~/.config on my Kubuntu machine), and change the line

Show Menu Bar=false to Show Menu Bar=true

and

MenuBar=Disabled to MenuBar=Enabled

I closed all my open kate windows, restarted, and my menu bar was back.

| improve this answer | |
0

Three things are required to get your menus back under the title bar.

  1. cd into your .config folder and execute:

    find ./ -type f -exec sed -i 's/MenuBar=Disabled/MenuBar=Enabled/g' {} \;
    
  2. In KDE settings > Window management > Menu tab > remove burger applications menu from title bar in both active and inactive windows

  3. In KDE settings > Startup > Services > disable the menu daemon

Plus if you want your top menus in kate, hit ctrl+m twice.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.