0

I have two computers both with Ubuntu 16.04. On my desktop, I create an ad-hoc network called "UbuntuTest". I make the Wi-Fi security WEP 128-bit Passphrase. Then on my laptop, I try to connect to this hotspot "UbuntuTest" using the key but it won't connect. It will try for about a minute and then it will disconnect.

The wireless card on my desktop is RT3092 Wireless 802.11n 2T/2R PCIe and on my laptop is Centrino Advanced-N 6235.

How can I fix this so I can connect my ubuntu laptop to a hotspot created by my ubuntu desktop?

I should also note that other devices can connect to the hotspot I create on my desktop (i.e. iPhone, Mac, and Windows)

Thanks!

EDIT:
I ran the script described on WiFi not Working Information.

The output of the script is at the following link script output (iwconfig is in the output, just search iwconfig). There are two networks shown in the output NetworkICanConnectTo (which is my usual home wifi) and NetworkICanNOTConnectTo (which is the wifi I create on my desktop).

EDIT 2:

I also tried connecting my laptop (and desktop) to a wifi created by a raspberry pi running raspbian Jessie lite and I still have the same problem. So to sum it up I'm having trouble connecting ubuntu to a network created by a linux machine.

  • The information missing is: Does it connect to other networks? – user589808 Apr 12 '17 at 22:13
  • I think what @CelticWarrior means by "it" is your ubuntu laptop. Note that for trouble shooting networking further information will be required. Please see askubuntu.com/questions/425155/… – Elder Geek Apr 12 '17 at 23:16
  • Yes, my laptop can connect to other networks. I figured more information would be needed but I've been at a loss for where to start, so thank you for the link. I'll run this script and update my post with the output. – Jonathon Gardner Apr 13 '17 at 0:21
  • Please post the output of iwconfig – Gansheim Apr 13 '17 at 0:39
1

It looks like you need to set your wifi interface to ad-hoc mode. Below are the instructions step by step to setup an ad-hoc network from Ubuntu Documentation

Linux to Linux peers

tested on 10.04 Netbook Remix using the Broadcom B43 proprietary driver. Broadcom STA did not work properly

  1. Right-mouse click the NetworkManager icon (top right)

  2. Select "Edit Connections"

  3. Click the "Wireless" tab

  4. Click "Add" to edit a new wireless connection

  5. On the wireless dialogue give the connection a name, e.g "Mochudi".

    1. SSID: "Mochudi". The SSID will appear on the NetworkManager for your other Peers

    2. Mode: Ad Hoc

    3. BSSID: leave blank

    4. MAC Address: leave blank

    5. MTU: leave as automatic

  6. Click "Apply"

  7. Click "Close"

If fixed IP addresses are required edit the IPv4 Settings Tab before closing NetworkManager above:

...as above then...

6a. Click "IPv4 Settings Tab"

Select Method "Manual"
Under Addresses click Add
Type your Address: 10.42.43.1
Type the Netmask: 255.255.255.0

Gateway: leave blank or 0.0.0.0 

6b. Click "Apply"

  1. Click "Close"

Do the above for each machine joining your fixed IP address Ad-Hoc network except assign a unique Address to each machine, so 10.42.43.1 becomes 10.42.43.2 for the second computer, 10.42.43.3 for the third, etc.

0

I was able to fix the problem. The above solution was helpful but I was not trying to do a peer connection but trying to have a computer act as a router. To fix my problem on my laptop (the device trying to connect to the network) I set my IPv4 Settings to manual by the following:

  1. Clicked network manager (top right) and selected edit connections.
  2. I then selected the connection that wasn't working (in my case "UbuntuTest") and clicked edit.
  3. Under Wi-Fi tab, I didn't change anything but my settings were SSID: "UbuntuTest", Mode: Client, and MTU: automatic.
  4. Under the IPv4 Settings, I changed the Method to Manual and under address, I added my IP address 10.42.43.2, set the Netmask to 255.255.255.0, and left the Gateway blank.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.