0

I have been using squid proxies with authentication on VPS servers running on Ubuntu 12.04, but for some reason have never been able to make it work on 14.04 using the same conf file, and i cant figure out what im doing wrong, but im assuming it's something in the conf file that needs to be changed.

My conf file currently looks like this and works fine on 12.04 (please not i removed "basic" from the ncsa_auth part in line 2, even though some guides say otherwise):

#Recommended minimum configuration:
auth_param basic program /usr/lib/squid3/ncsa_auth /etc/squid3/squid_passwd
acl ncsa_users proxy_auth REQUIRED
acl manager proto cache_object
acl localhost src 127.0.0.1/32
acl to_localhost dst 127.0.0.0/8
acl localnet src 192.168.100.0/24
acl localnet src 194.192.151.254
acl SSL_ports port 443
acl Safe_ports port 80          # http
acl Safe_ports port 21          # ftp
acl Safe_ports port 443         # https
acl Safe_ports port 70          # gopher
acl Safe_ports port 210         # wais
acl Safe_ports port 1025-65535  # unregistered ports
acl Safe_ports port 280         # http-mgmt
acl Safe_ports port 488         # gss-http
acl Safe_ports port 591         # filemaker
acl Safe_ports port 777         # multiling http
acl Safe_ports port 591         # filemaker
acl Safe_ports port 777         # multiling http
acl CONNECT method CONNECT

http_access allow ncsa_users
http_access allow manager localhost
http_access deny manager
http_access deny !Safe_ports
http_access allow localhost
http_access allow localnet
icp_access deny all
htcp_access deny all

http_port 3128
hierarchy_stoplist cgi-bin ?
access_log /var/log/squid3/access.log squid

#Suggested default:
refresh_pattern ^ftp:           1440    20%     10080
refresh_pattern ^gopher:        1440    0%      1440
refresh_pattern -i (/cgi-bin/|\?) 0 0% 0
refresh_pattern .               0       20%     4320
# Leave coredumps in the first cache dir
coredump_dir /var/spool/squid3

# acl whitelist dstdomain "/etc/squid3/whitelist.txt"

# Allow localnet machines to whitelisted sites
# http_access allow localnet whitelist

`
# block all other access http_access allow  all`
  • What happens when you try and run the squid proxy with this config? Does it do nothing? Does it error out when starting up? – Thomas Ward Apr 12 '17 at 16:57
  • It just doesnt allow any access to websites when i use it in browser. I checked my VPS settings, and it's not because ports are blocked, which i have had problems with previously – Mikkel Apr 12 '17 at 16:59
  • Different version of squid. The default config file is very long (4,000 + lines last I looked) and WELL COMMENTED. I suggest you take a look at the default config file to see if there are any syntax changes. Also look at your logs for error messages. – Panther Apr 12 '17 at 17:29
  • Well, i use same squid install command for both Ubuntu versions and install squid3 on both versions...do you still think they are differen then? – Mikkel Apr 12 '17 at 17:36
  • The version of squid is different or you have a syntax error, not sure. What do the logs show ? – Panther Apr 12 '17 at 18:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.