0

Hallo I just have a VPS provisioned with Ubuntu 14.04.5

I already had a VPS provisioned and working fine, with the same provider.

This time, I'm experiencing some issues:

  • bash completion not working, neither history command (arrow up); moving cursor across the line with left/right arrow results in character codes being printed (eg. ^[[C ): already tried installing/reinstalling bash-completion, updating .bashrc, logging off and on; even if the login shell for the user is bash, I tried chsh. No luck.
  • some commands missing: ll, logout, they give me sh: ll: not found
  • some other minor differences: like the cwd path missing from the prompt

Could these facts altogether be of same meaning to you? Thanks in advance

  • 2
    sh: ll: not found really does suggest this is a sh versus bash issue - are you testing this in a gnome-terminal or in a CLI environment? Did you confirm that chsh changed your login shell (e.g. getent passwd $USER)? – steeldriver Apr 12 '17 at 13:27
  • Are you sure you are running bash at all? If set |grep BASH does not produce tons of output, you are not running bash. One reason could be that /bin/sh is linked to something other than bash. – Harald Apr 12 '17 at 14:05
  • ... or that you've set your terminal emulator preferences to use /bin/sh explicitly – steeldriver Apr 12 '17 at 14:34
  • in the meanwhile I ran a sudo aptitude update && sudo aptitude full-upgrade -y sudo apt-get build-dep build-essential -y and now everything is ok. Sounds weird to me. – En-j Apr 13 '17 at 7:47

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.