1

HP laptop
Ubuntu 14.04 (64 bit) Geforce 830M Nvidia Driver -375.39(Latest Checked in Nvidia Site)

My requirements:

  1. I have to install Nvidia Latest drivers suppoeted for my system(375.39)
  2. After that I have to install cuda 8.0 (Latest)
  3. Then, I have to install GPU version Tensorflow

I tried installing Nvidia-375.39 by downloading running it as root. I got the error as "X server is currently running..Stop it and so on..." I have completely zero knowledge on X server..."Using: nvidia-installer ncurses user interface -> Detected 4 CPUs online; setting concurrency level to 4. -> The file '/tmp/.X0-lock' exists and appears to contain the process ID '16666' of a runnning X server. ERROR: You appear to be running an X server; please exit X before installing." Can some one help me on this

3

You need to stop lightdm to install Nvidia drivers.

sudo service lightdm stop

But this will stop the whole desktop. So do the following steps.

  1. Press Ctrl+Alt+F1 to go to non-GUI mode. Enter your username and password.

  2. Stop lightdm with the above command.

  3. Now you can install Nvidia drivers and install CUDA.

  4. Once you finished installing it. Restart your computer

    shutdown now
    
  5. Now turn on your computer like you normally do.

You will be back with GUI.

  • I did that earlier , but while installing the Driver in that mode , i found the error "You are currently running X server ............". I tried both in Normal Terminal and in that mode (Ctrl+Alt+F1). I am getting same error message "Using: nvidia-installer ncurses user interface -> Detected 4 CPUs online; setting concurrency level to 4. -> The file '/tmp/.X0-lock' exists and appears to contain the process ID '16666' of a runnning X server. ERROR: You appear to be running an X server; please exit X before installing. – Harish Bodduna Apr 12 '17 at 12:54
  • Thank you for your insights @Shreyash S Sarnayak Can you help me more with that error log file – Harish Bodduna Apr 12 '17 at 12:58
  • Did you do step 2? Stop lightdm using sudo service lightdm stop? – Shreyash S Sarnayak Apr 12 '17 at 13:06
  • Yes i did that command . And from Additional Driver tool , i defaulteed the drivers to Nvidia 375.39.....But still i am getting the same error of "X server" – Harish Bodduna Apr 12 '17 at 13:12
  • 1
    Ohh.. If the Nvidia 375.39 is selected, then you don't need to install it again. You can skip it. And when you are installing CUDA it will ask to install the Nvidia driver (361.., probably) even then don't install it again (This driver is old and too buggy for ubuntu). – Shreyash S Sarnayak Apr 12 '17 at 13:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.