0

I am using ubuntu 16. Whenever I am connected to a WiFi, Internet stops working after few minutes, even when the WiFi shows connection. I have to disconnect and then connect again to that WiFi.(Internet starts working) This process keeps on coming after every 10-15 minutes. After running network diagnostic test my result is, paste.ubuntu.com/24373253

  • Welcome to AskUbuntu! Could you please run the network diagnostics and edit your question to include a link to the result? I know it may seem a bit overwhelming for a novice but your info so far is a bit vague and the diagnostics will likely cover all options that may cause your issue. Thanks. – David Foerster Apr 12 '17 at 12:48
  • Hi, did you check if anything changed from when it was working to when it stopped? For example, check your IP, Gateway and DNS when it's working and when it stop working and see if they are different. Also, please do some tests likes trying to ping the gateway, google dns etc. Does it happens only on wifi or wired connection as well? All wifi or a particular one? Thanks – Adonist Apr 12 '17 at 16:16
  • I have added link to the result of running network diagnostic test. Please check. – Aadersh Agarwal Apr 13 '17 at 12:30
0

For me this ugly workaround does the job, until I find a better solution:

Try the following command when the connection drops next time:

sudo ip link set <your device> down && sudo ip link set <your device> up

If the connection comes back add this command to crontab:

sudo crontab -e

Than add this line:

  * *  *   *   *     ip link set <your device> down && ip link set <your device> up

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.