1

I am a newbie in Ubuntu / linux system. I was attempting to install my Teletalk 3g flash Modem in my Ubuntu 16.04 LTS 64 bits system. i have tried this guide with no luck, also tried sakis3g approach, that also stops with error. and

when I run

sudo bash install.sh 

The following operations occurs and throws a lots of error.

..................start install.................
*** Check for root...ok...
./zr: error while loading shared libraries: libusb-0.1.so.4: cannot open shared object file: No such file or directory
Get resouse file successfully.
..........delete /etc/udev/rules.d/7-zte-mutil_port_device.rules ok...........
Teletalk_3G/usr/share/applications/Teletalk_3G.desktop
Teletalk_3G/usr/share/pixmaps/Teletalk_3G.png
.
.
.
Teletalk_3G/Language/
Teletalk_3G/qss/
Teletalk_3G/Skin/
Teletalk_3G/
ls: cannot access '/usr/share/applications/desktop.*.cache': No such file or directory
******Begin to /opt/Teletalk_3G/driver
this is linux driver installtion
make -C /lib/modules/4.8.0-46-generic/build M=/tmp/ONDA_driver_install_V3.42 modules
make[1]: Entering directory '/usr/src/linux-headers-4.8.0-46-generic'
  CC [M]  /tmp/ONDA_driver_install_V3.42/onda.o
/tmp/ONDA_driver_install_V3.42/onda.c:21354:16: error: ‘usb_serial_probe’ undeclared here (not in a function)
  .probe      = usb_serial_probe,
                ^
/tmp/ONDA_driver_install_V3.42/onda.c:21355:16: error: ‘usb_serial_disconnect’ undeclared here (not in a function)
  .disconnect = usb_serial_disconnect,
                ^
/tmp/ONDA_driver_install_V3.42/onda.c: In function ‘onda_init’:
/tmp/ONDA_driver_install_V3.42/onda.c:21433:11: error: implicit declaration of function ‘usb_serial_register’ [-Werror=implicit-function-declaration]
  retval = usb_serial_register(&onda_1port_device);
           ^
/tmp/ONDA_driver_install_V3.42/onda.c:21446:2: error: implicit declaration of function ‘usb_serial_deregister’ [-Werror=implicit-function-declaration]
  usb_serial_deregister(&onda_1port_device);
  ^
/tmp/ONDA_driver_install_V3.42/onda.c: In function ‘onda_instat_callback’:
/tmp/ONDA_driver_install_V3.42/onda.c:21510:2: error: implicit declaration of function ‘dbg’ [-Werror=implicit-function-declaration]
  dbg("%s", __func__);
  ^
/tmp/ONDA_driver_install_V3.42/onda.c:21548:3: error: called object ‘err’ is not a function or function pointer
   err("%s: error %d", __func__, status);
   ^
/tmp/ONDA_driver_install_V3.42/onda.c:21505:6: note: declared here
  int err;
      ^
In file included from ./include/linux/module.h:18:0,
                 from /tmp/ONDA_driver_install_V3.42/onda.c:20880:
/tmp/ONDA_driver_install_V3.42/onda.c: In function ‘__check_debug’:
./include/linux/moduleparam.h:344:67: error: return from incompatible pointer type [-Werror=incompatible-pointer-types]
  static inline type __always_unused *__check_##name(void) { return(p); }
                                                                   ^
./include/linux/moduleparam.h:396:35: note: in expansion of macro ‘__param_check’
 #define param_check_bool(name, p) __param_check(name, p, bool)
                                   ^
./include/linux/moduleparam.h:146:2: note: in expansion of macro ‘param_check_bool’
  param_check_##type(name, &(value));       \
  ^
./include/linux/moduleparam.h:126:2: note: in expansion of macro ‘module_param_named’
  module_param_named(name, name, type, perm)
  ^
/tmp/ONDA_driver_install_V3.42/onda.c:21598:1: note: in expansion of macro ‘module_param’
 module_param(debug, bool, S_IRUGO | S_IWUSR);
 ^
cc1: some warnings being treated as errors
scripts/Makefile.build:295: recipe for target '/tmp/ONDA_driver_install_V3.42/onda.o' failed
make[2]: *** [/tmp/ONDA_driver_install_V3.42/onda.o] Error 1
Makefile:1491: recipe for target '_module_/tmp/ONDA_driver_install_V3.42' failed
make[1]: *** [_module_/tmp/ONDA_driver_install_V3.42] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-4.8.0-46-generic'
Makefile:16: recipe for target 'modules' failed
make: *** [modules] Error 2
this  is customized kernel ,kernel version is: 4.8.0-46-generic
enter customize_driver_install function
cp: cannot stat 'onda.ko': No such file or directory
modprobe: FATAL: Module onda not found in directory /lib/modules/4.8.0-46-generic
disselfirefox.pp driver_install.run nm.pp se End to /opt/Teletalk_3G/driver
udevadm is exist!
install completed!!!
....After setup, you will find the Teletalk 3G in "Applications->Internet->Teletalk 3G". Click the Teletalk 3G and the application will run
press any key to continue.... 
Testability plugin /usr/lib/i386-linux-gnu/qt4/plugins/testability/libtestability.so load failed with error:The shared library was not found.
QObject::connect: Cannot connect (null)::clicked() to UUFormConnect::slotToConnectLogForm()
QObject::connect: Cannot connect (null)::clicked() to UUFormConnect::slotChangeApn()
QObject::connect: Cannot connect (null)::clicked() to UUFormMain_Bengal_Teletalk::slotMainMenu()
QObject::connect: Cannot connect (null)::clicked() to UUFormMain_Bengal_Teletalk::slotSettingButtonClicked()
QObject::connect: Cannot connect (null)::clicked() to UUFormMain_Bengal_Teletalk::slotStkButtonClicked()
QObject::connect: Cannot connect (null)::clicked() to UUFormMain_Bengal_Teletalk::slotHelpButtonClicked()
QObject::connect: Cannot connect (null)::clicked() to UUFormMain_Bengal_Teletalk::slotVoiceRecordButtonClicked()
QObject::connect: Cannot connect (null)::clicked() to UUFormMain_Bengal_Teletalk::slotHomeButtonClicked()
QObject::connect: Cannot connect (null)::clicked() to UUFormMain_Bengal_Teletalk::slotNewReciveSMSClicked()
QObject::connect: Cannot connect (null)::clicked() to UUFormMain_Bengal_Teletalk::slotMissedCallSignClicked()
QObject::connect: Cannot connect (null)::clicked() to UUFormMain_Bengal_Teletalk::slotCallingSignClicked()
QObject::connect: Cannot connect (null)::clicked() to UUFormMain_Bengal_Teletalk::slotMissedCallSignClicked()
QObject::connect: Cannot connect (null)::clicked() to UUFormMain_Bengal_Teletalk::slotShowV4v6Info()
QObject::connect: Cannot connect (null)::triggered(QAction *) to UUFormMain_Bengal_Teletalk::slotClickLanMenu(QAction *)
QObject::connect: Cannot connect (null)::aboutToShow() to UUFormMain_Bengal_Teletalk::slotLanMenuWillShow()
"sni-qt/4167" WARN  16:52:06.295 void StatusNotifierItemFactory::connectToSnw() Invalid interface to SNW_SERVICE 
QObject::connect: Cannot connect (null)::clicked() to UUFormInputPin::slotInputPinCancel()
QObject::connect: Cannot connect (null)::clicked() to UUFormInputPuk::slotInputPukCancel()
begin bind slotSystermSleeping(), slotSystermResuming(), UUPowerStateListener::startListen_Linux() 
Object::connect: No such signal org::freedesktop::UPower::Sleeping()
Object::connect: No such signal org::freedesktop::UPower::Resuming()
end bind slotSystermSleeping(), slotSystermResuming(), UUPowerStateListener::startListen_Linux() 
The futex facility returned an unexpected error code./bin/Teletalk_3G: line 14: /usr/lib/CoreSDK.so:: No such file or directory
  • "sudo bash install.sh" in-fact – fahad032 Apr 12 '17 at 11:04
0

Install wvdial:

sudo apt-get install wvdial

and use network manager i.e insert the modem (with SIM) and wait until a mobile broadband entry shows up in the network manager. Click on the mobile broadband entry and setup your connection. It provides selecting common operators like GP, Robi etc.. or you can set the APN and other options manually.

If no mobile broadband connection shows up on network manager, try uninstalling any previous installation:

cd /opt/Teletalk_3G
sudo ./uninstall

If it still doesn't show up, reboot and wait. If that doesn't work, unmount (eject) the modem (not physically though:D, right click on the modem usb device on file manager and unmount/eject), It should show up on your network manager soon.

  • I have tried with your answer, still the same errors. – fahad032 Apr 12 '17 at 15:27
  • @fahad032 : the libusb error should be gone and you should be able to launch it even with errors. (use sudo or gksudo to launch) – Jahid Apr 12 '17 at 17:32
  • @fahad032 : Though I remember having trouble in 16.04 and sticking with the default method (with network manager) which by far seems to be the best option if you don't care about anything else other than connecting to Internet. You will need to install wvdial though – Jahid Apr 12 '17 at 17:35
  • @jahid: yeah, i don't care about any other thing except to connecting to the Internet (of-course i care about the system effects, if there is any ), can you please guide me for the wvdial procedure, or a link that describes this approach. Thanks – fahad032 Apr 13 '17 at 4:00
  • @jahid unfortunately, though this app runs, it can't detect my modem, so no connect options as well, that is the primary goal here( to connect to the Internet using this modem ). – fahad032 Apr 13 '17 at 4:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.