0

I have recently installed an external hard drive USB on my Ubuntu 11.10 Server but I cannot use Apache to allow web browsing. I think it is a permissions problem but I cannot change the permissions on SSH using chmod.

I have webmin installed but that seems to be no help either.

Any offers greatly received.

CHRIS

  • More information is needed. Normally you would transfer the files to /var/www , so how did you configure apache and what makes you think it is a permissions problem ? Second, what file system is on the external drive ? If you ar going to use the drive primarily on Linux , best back up the data and format it to ext4 (or other linux native file system). You can use permissions with ntfs, but it requires permissions as an option in fstab. – Panther Dec 25 '11 at 17:59
1

Is the external hard drive formatted as FAT32? FAT32 doesn't exactly support all the permissions settings that most Linux filesystems do, so it will let you try to change the permissions of files on it, but then the changes won't "stick". (I've done it myself before).

  • Thanks for the two answers and at Christmas - that is devotion. The external hard drive is FAT32 and what you describe Azendale is exactly what I have. Really did that so that I could swap the HD between a laptop and the server. Ive configured the Apache server to use the files on the external drive in my case /media/HITACHI/ etc when serving web pages. Other virtual servers go to either the home directory or /var/www – Chris Dec 26 '11 at 9:31
  • I believe that you can set some setting when mounting the drive so that the permissions would be correct by default, but I've never done it myself. – Azendale Dec 31 '11 at 17:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.