0

I've had some troubles with my wifi using Ubuntu. It seems like I can't connect to modems set to a channel above 11. However I can connect to such modem in windows, therefore the problem must be related to ubuntu and to the driver provided for my broadcom bcm4313. I tried switching to the default driver instead of the one coming from the bcmwl-kernel-source which is the one I am running right now as you can see here but the problem persists. Previously I had jumped out of the problem setting the channel on 11, but I'd like to connect also to modems that don't necessarily rely on that channel and below, as I can do in windows. One more detail is that since I switched to brcmsmac I see this message when booting:

Support for cores revisions 0x17 and 0x18 disabled by module param allhwsupport=0. 
Try b43.allhwsupport=1.
4
  • and when you did try b43.allhwsupport=1 as suggested what happend?
    – Rinzwind
    Apr 11, 2017 at 13:22
  • @Rinzwind I did not try it because it automatically stopped showing when switching to the bcmwl-kernel-source driver, and I wouldn't know how to try it since I don't know which file it refers to, I guess I might try but I didn't think it could be related with the driver capability of detecting the modem depending on what channel it is set on Apr 11, 2017 at 13:53
  • I thought it wasn't an important message so it could be that I undehestimated it, but reading some article around I found that it was related to the b43 firmware, which some were arguing not to be compatible with bmc4313, so I didn't know what to do about it @Rinzwind Apr 11, 2017 at 13:58
  • Time to alert the resident expert @chili555 He will know what to do :D
    – Rinzwind
    Apr 11, 2017 at 14:01

1 Answer 1

0

Unfortunately this is an issue with all broadcom modules and they seem to be limited to channels 1-11 in 2.4GHz

You might be able to use the patch at https://github.com/respeaker/openwrt/blob/master/package/kernel/mac80211/patches/850-brcmsmac-remove-extra-regulation-restriction.patch to patch the kernel source but it didn't work when I tried it with my BCM4313

2
  • Yes I've read posts stating the same, but can't be just the chip because I can see my connection in windows. What I will try is trying to install the driver I have in windows with wine, and then I'll see if it goes fine Apr 13, 2017 at 14:56
  • I said modules as in the linux drivers is what prevents those channels from being used but broadcom could have put something in the firmware
    – Jeremy31
    Apr 13, 2017 at 17:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.