1

I want to configure the HP LaserJet Pro M132nw MFP to scan in Ubuntu 16.04

Installed hplip 3.16.11 Installed printer through:

Hp-setup -i

The printer work fine, but when I'm trying to scan there is the message that it can not find the scanner.

sane-find-scanner

User @ test: ~ $ sudo sane-find-scanner

  # Sane-find-scanner will now attempt to detect your scanner. If the
  # Result is different from what you expected, first make sure your
  # Scanner is powered up and connected to your computer.

  # No SCSI scanners found. If you expect something different, make sure that
  SCSI driver for your SCSI adapter.

Found USB scanner (vendor = 0x03f0 [HP], product = 0x622a [HP LaserJet MFP M129-M134]) at libusb: 001: 010
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # Can not be detected by this program.

scanimage -L

User @ test: ~ $ sudo scanimage -L

No scanners were identified. If you were expecting something different,
Check that the scanner is plugged in, turned on and detected by the
Sane-find-scanner tool (if appropriate). Please read the documentation
Which came with this software (README, FAQ, manpages).

Printer settings (CUPS)

Description: HP_LaserJet_MFP_M129-M134
Location:
Driver: HP LaserJet MFP m129-m134, hpcups 3.16.11 (color)
Connection: hp: / usb / HP_LaserJet_MFP_M129-M134? Serial = VNC8Y01706
Defaults: job-sheets = none, none media = iso_a4_210x297mm sides = one-sided

GUI Simple scan - sees the scanner in the settings, but when you try to scan it produces:

"Failed To Scan, Unable to connect to scanner"

Reinstalled the hp-plugin

Added a line to /lib/udev/rules.d/40-libsane.rules

 # Hewlett-Packard LaserJet M132NW ATTRS {idVendor} == "03f0", ATTRS {idProduct} == "622a", ENV {libsane_matched} = "yes"

Added a line in /etc/sane.d/hp.conf

# HP M132NW
Usb 0x03f0 0x622a

User in groups:

User @ test: ~ $ groups
User adm lp cdrom sudo dip plugdev lpadmin sambashare scanner

What else can I try?

1

I had the same problem. For me the solution was this: https://wiki.archlinux.org/index.php/SANE/Scanner-specific_problems#HP In other words, in the Terminal: "hp-setup -i" "hp-plugin -i" "hp-scan" (I installed XSane and tried it before that. It didn't seem to help, so probably is irrelevant...) After that Simple Scan worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.