1

Unable to boot Windows 7 after Ubuntu installation because no boot menu is shown. Both OS are in /dev/sda:

fdisk -l /dev/sda
Disque /dev/sda : 238,5 GiB, 256060514304 octets, 500118192 secteurs
Unités : sectors of 1 * 512 = 512 octets
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x063924fd

Périphérique Amorçage     Start       Fin  Secteurs  Size Id Type
/dev/sda1                  2048   2101247   2099200    1G  7 HPFS/NTFS/exFAT
/dev/sda2    *          2101248 388007935 385906688  184G  7 HPFS/NTFS/exFAT
/dev/sda3             388009982 470624255  82614274 39,4G  5 Étendue
/dev/sda4             470624256 495912959  25288704 12,1G  7 HPFS/NTFS/exFAT
/dev/sda5             388009984 470624255  82614272 39,4G 83 Linux

Partition table entries are not in disk order.

(when I first installed Linux, the partition tool told me that sda2 was unknown).

I tried:

sudo update-grub
/boot/vmlinuz-4.8.0-36-generic
/boot/initrf.img...
Found memtest86+ image: /boot/memtest...elf
Found memtest86+ image: ....bin

No error but still can't choose OS.

boot-repair

Nothing changed after doing recommended steps. And in advanced options, I can't change flag to sda2.


When I try to mount sda2 under Ubuntu (because I was afraid to lose stuff), it fails too:

mount /dev/sda2 /dir
NTFS signature is missing.
Failed to mount sda2: invalid argument.
The device sda2 doesn't seem to have a valid NTFS.

I also tried lilo:

sudo apt-get install lilo
sudo lilo -M /dev/sda2 mbr

But nothing changed too.


I tried repair boot from Windows 7 recovery tools (USB iso Boot): recommended tool failed. And from the command line:

bootrec.exe /FixMbr
bootrec.exe /FixBoot

Makes the computer go into boot looping.


Bootinfoscript output: http://www.heypasteit.com/clip/02JPIN


Editing /etc/grub.d/40_custom:

menuentry 'Windows 7 (loader)' --class windows --class os {
        insmod part_msdos
        insmod ntfs
        set root='hd0,msdos2'
        chainloader +1
}

And

sudo update-grub2

Still no boot menu.

  • What famous issue? What happens when you try to boot? Can you see a boot menu? Is there no boot menu? Is there a boot menu but selecting one of the options gives an error? What error? How are you trying to mount sda2? Using what exact command? Please edit your question and clarify. We can't help you unless you give us the relevant details. – terdon Apr 11 '17 at 10:40
  • No boot menu, it starts automatically to Ubuntu. And I try to mount with "mount /dev/sda2 /dir" under Ubuntu cli and sudo. Sorry about the lack of details, I tried so many things that I can't remember all of them. – hakhasan Apr 11 '17 at 10:45
  • Please edit your question to add more details. Show us the exact commands, and the exact error messages. At the very least, edit and explain what is happening (no boot menu) you haven't even told us that! Why are you mounting that partition anyway? – terdon Apr 11 '17 at 10:52
  • Thanks for your time. Anything else I can add? – hakhasan Apr 11 '17 at 11:07
  • Check whether you can boot Windows from BIOS. If so then installing bootloader will do the job – Pranal Narayan Apr 11 '17 at 11:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.