13

There are no options to disable 'tap-to-click' in Mouse and Touch-pad settings, but there have always been in previous Ubuntu releases.enter image description here

5
  • Can this be made active now? 17.04 stable is out.
    – user308393
    Apr 13, 2017 at 15:48
  • Nominated for re-opening.
    – Elder Geek
    Apr 13, 2017 at 15:50
  • 1
    Try gsettings set org.gnome.desktop.peripherals.touchpad tap-to-click false. Does this work?
    – Seth
    Apr 13, 2017 at 15:54
  • Already tried gsettings (before posting here). Has no effect.
    – user308393
    Apr 13, 2017 at 18:11
  • @user308393 That exact schema? Did you get any errors or does it go through properly?
    – Seth
    Apr 13, 2017 at 21:26

2 Answers 2

19

Just registered to spread the solution to this annyoing problem.

Make sure you have package xserver-xorg-input-libinput installed. Then you need to remove package xserver-xorg-input-synaptics and restart. After the restart you have all the options back in the GUI.

Everything is handled by xserver-xorg-input-libinput now. xserver-xorg-input-synaptics is interfering this.

4
  • 1
    In my case, xserver-xorg-input-libinput was already installed. All I had to do was remove xserver-xorg-input-synaptics and reboot. Thanks!
    – user308393
    Apr 14, 2017 at 12:01
  • thanks a lot, this helped. how this managed to pass beta tests is beyond me...
    – stebu92
    Apr 18, 2017 at 8:39
  • Exactly my problem on an Asus UX501V!
    – rtindru
    Apr 30, 2017 at 13:56
  • This also works on Ubuntu 17.10. I just had to remove xserver-xorg-input-synaptics and restart, and all the settings were there!
    – ketil
    Feb 3, 2018 at 8:14
2

It is also possible to disable tap-to-click for the synaptics driver by changing its configuration in /usr/share/X11/xorg.conf.d/ to set Option "MaxTapTime" "0". Here is some documetation on synaptics driver configuration options.

Switching from xserver-xorg-input-synaptics to xserver-xorg-input-libinput did give me the option in the settings UI to disable tap-to-click, which worked; however, the driver switch also resulted in the loss of the ability to right-click with a two-finger click.

This was for a Dell XPS 13.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .