9

I accidentally installed ubuntu-gnome-desktop (initially with lightdm, and later switched to gdm3) on my heavily customized Ubuntu (Unity) 16.10 environment. Yikes! Now a bunch of stuff in Unity doesn't work as it did before. I need help fixing some unresolved problems. Can you please help?

  1. Desktop problems

    • In Unity, I can't set desktop background
    • In Unity, the superkey doesn't bring up dashboard unless another application is in the foreground
    • In Unity, the desktop files and folders are gone
    • In Unity, I can't right-click on the desktop and bring up the contextual menu
  2. Font problem

    • In Unity, the default fonts have changed
  3. Touchpad problems

    • In Unity, the touchpad-indicator crashes, looking for Synaptics touchpad driver
    • In Unity, the touchpad "tap to single-left-click" no longer works
    • In Unity, the touchpad preferences are missing in System Settings/Mouse & Touchpad panel
    • In Gnome, the touchpad preferences do show up in System Settings

I believe that this is because xserver-xorg-input-libinput got installed, thereby disabling the Synaptics touchpad driver. Can I safely uninstall this, and hopefully re-enable the Synaptics driver, without breaking anything in the Unity desktop, or the Gnome desktop?

  1. Login screen problem

    • The main login screen background is black. How do I get any background to show again?
  2. Default DE problem

    • The login area always shows "Gnome (Default)" in the list of desktop environments. How do I change the default to "Ubuntu (Default)"?
  3. Boot/shutdown screens problem

    • Boot and shutdown screens are Gnome animation/text screens. How do I bring back normal Ubuntu/Unity boot/shutdown screens?
15
  • @ElderGeek thanks for your input. I haven't tried to remove ubuntu-gnome-desktop for fear of creating more Unity problems. I figure that now that it's installed, I might as well try it (I was going to install it into a Virtualbox environment to test it) since we're all going to it next year. By pristine 16.10 I meant a long-running, clean, problem-free, installation with a ton of apps and customizations.
    – heynnema
    Apr 10, 2017 at 23:22
  • @ElderGeek I'll go and change "pristine" in my question to something else. No, I meant that we'll all be going to Gnome in 18.04... if plans stick to schedule. That's why I wanted to play with Gnome... but in a VB environment... not my normal Unity machine.
    – heynnema
    Apr 10, 2017 at 23:50
  • In stock Ubuntu, setting the session background image also sets the login screen background image. Is that no longer working? Apr 10, 2017 at 23:59
  • @OrganicMarble thanks for your input. Let me see if I get this straight... my lock screen is the same as my desktop background, but my login screen is black with the normal username/password login area.
    – heynnema
    Apr 11, 2017 at 0:02
  • 1
    @OrganicMarble only one problem left to solve!
    – heynnema
    Apr 12, 2017 at 14:48

2 Answers 2

9

Fixes for my ubuntu-gnome-desktop post-installation problems...

  1. Desktop problems: Use the Gnome Tweak Tool, and set "Icons on Desktop" to ON

  2. Font problem: Use the Unity Tweak Tool, and set the fonts back to Ubuntu default fonts

  3. Touchpad problems: Fix taken from How to invert touchpad scrolling on Ubuntu 16.04

If you use libinput, then add a config file to /etc/X11/xorg.conf.d/ such as 20-touchpad.conf with this content:

Section "InputClass"
    Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
        Option "NaturalScrolling" "off"
        Option "MiddleEmulation" "on"
        Option "Tapping" "on"
        Option "DisableWhileTyping" "on"
        Option "PalmDetection" "True"
EndSection
  1. Login screen problem: User desktop must be set to display a desktop picture, not a solid color

  2. Default DE problem:

In terminal...

gksudo gedit /etc/lightdm/lightdm.conf

add in this text snippet under [SeatDefaults]...

[SeatDefaults]
user-session=ubuntu

don't duplicate [SeatDefaults] if it's already there.

  1. Boot/shutdown screens problem: Partially taken from How do I revert the Plymouth theme back to default after purging Kubuntu?

In terminal...

ls -al /etc/alternatives/*plymouth*
sudo update-alternatives --config default.plymouth
sudo update-alternatives --config text.plymouth
7
  • FYI: Regarding 6 my testing indicates that sudo update-initrams -u isn't required. Simply choosing the correct option from sudo update-alternatives ... and rebooting is sufficient.
    – Elder Geek
    Apr 12, 2017 at 21:50
  • @ElderGeek and the boot screen (not the shutdown/reboot screen) is correctly changed to the desired type? It would be interesting to see if the mod date of /boot/initrd.img* changes after the update-alternatives... can you check your mod dates?
    – heynnema
    Apr 12, 2017 at 21:59
  • If by boot screen you mean ubuntu with the 5 dots, then as opposed to the weird u's on the gnome boot screen, then yes. If you mean something else can you define it for me?
    – Elder Geek
    Apr 12, 2017 at 22:03
  • @ElderGeek yes, you have it right... the Ubuntu/Unity 5 dots boot screen vs the Gnome interlocked U's boot screen. Assuming that you didn't do the update-initramfs command, do a ls -al /boot/initrd* and see if the most recent one has todays date for a mod date.
    – heynnema
    Apr 12, 2017 at 22:06
  • Why not try it yourself? Switch back to the gnome boot screen and don't update-initramfs and there;s your proof. When done, simply change it back! :-)
    – Elder Geek
    Apr 12, 2017 at 22:09
2

The Touchpad problem could be resolved by removing the xserver-xorg-input-libinput package.

sudo apt remove xserver-xorg-input-libinput

I had the same problem and removing package solved it without making any other problems. Note: I have removed Gnome Shell completely before removing this package.

Source: this Ubuntu Forums post

2
  • This was a part of my original question. Further research is required, as I read one post where the user had removed this package, and it broke their system. In the mean time, I have proposed an elegant solution that works.
    – heynnema
    Apr 26, 2017 at 12:31
  • I had the same problem, removed the package and everything is working now.
    – Hamed
    Apr 27, 2017 at 5:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .