Sometime when I connect my headphones on my pc. They doesn't work and I can't understand. I have to turn off my pc two or three times to use it again. Someone have found a solution?

Dell xps 15 9550 ubuntu 16.04

  • Literally having the same issue - really kicked in now where it's not playing at all
    – pee2pee
    Apr 10 '17 at 19:57
  • Same. Dell xps 15 9550 and no sound. I've tried about a dozen fixes from here and elsewhere. Nothing obvious from /var/log/syslog. Sinks look normal. alsa-info.sh didn't show any errors except some video card stuff. Grr.
    – labyrinth
    Jul 10 '17 at 14:25
  • I tried overriding with hdajackretask, but no luck.
    – labyrinth
    Jul 10 '17 at 14:48
  • Discouraging. This looks like the most recent word, but this user didn't have any luck either: ubuntuforums.org/… UPDATE: I think I have a workaround from that forum, but it isn't pretty. I'll put it as an answer below until something better comes along.
    – labyrinth
    Jul 10 '17 at 14:52

Not a real fix, but a workaround.

  1. Log in
  2. Go to power icon in upper right, do 'suspend'
  3. After machine suspends, press the laptop power button
  4. Log in again
  5. Plug in headphones. (When prompted on what kind of device, I just pressed 'cancel')

Headphones should work now. Not pretty, but at least I can use headphones. I am able to unplug and plug the headphones in and it still works. But after a reboot, you have to do these steps again.

  • It works! At least saves my time in random number of restarts. Disappointed to see these from Dell + Ubuntu.
    – NehaM
    Sep 15 '17 at 8:37

It's a known Kernel bug (109841) and therefore obviously an Ubuntu bug (1575078), too.

Many bugfixes seem to include the creation/editing of /etc/modprobe.d/alsa.conf with different effects.

  1. This configuration in alsa.conf seems to be the best solution for older Ubuntu versions than 17.04:

options snd-hda-intel single_cmd=1 probe_mask=1 model=dell-headset-multi

or if you want avoid the dialogue asking which device you inserted into the headphone jack:

options snd-hda-intel single_cmd=1 probe_mask=1 model=headset-mic

  1. Another thing that worked for some folks is to call
$ alsactl restore

from command line when sound is not working.

  1. Hibernating and waking up the machine sometimes works as well.

Good luck!


Sorry, I can't add a comment (low karma), and actually, this is not a real answer.

Probably, the best thing you can do now: provide MORE information about system configuration, at least, related to sound subsystem.

Step one: check your headphones with the other device

Step two: check volume settings. For example, my PC turns sound off (or restore the previous volume level), when I plug anything to audio-out

Step three: connect your headphones and open Sound settings, try to run sound test. Run the same test without headphones, or with the other headphones.

If these actions will not help — make a screenshot of all tabs in Sound settings and attach them to your question.

But all this actions are not a real diagnostic, these are the necessary steps, you should do, before creating a question;) Probably, it is better to gather some information from system logs. But at first: eliminate obvious causes.

PS: 1-2-3-N reboots - it is not a diagnostic tool;)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.