2

I am experiencing a weird issue with Chrome on Ubuntu Gnome:

I can't put Chrome on fullscreen because it freezes the system. Actually the system just seems to be frozen, but I can't use it because it only show a static blueish screen (as the hue were changed to blue) from Chrome on top of everything.

The problem doesn't occur when using Opera.

I am able to resume normal use after restarting Gnome Shell (inputting r after pressing Ctrl+F2).

I did find some similar issues from other users, but can't find a solution/workaround:

OS Info:

  • Ubuntu 17.04 64-bit (dev branch)
  • GNOME Shell 3.24.0
  • NVIDIA 378.13
  • Google Chrome 58.0.3029.54 beta
| improve this question | | | | |
  • 1
    Google Chrome is beta and Ubuntu 17.04 is Dev branch, might have to do something with two relatively unstable software. – Sumeet Deshmukh Apr 10 '17 at 16:24
  • Very much probably! I also tried Chrome stable, but don't want to downgrade the OS version. As per the referenced links, it seem to also occur in a similar form in other stable releases. – chrisandrew.cl Apr 10 '17 at 17:28
2

I am using openSuse Tumbleweed on a Lenovo T460s and experiencing the same problem after updating gnome to 3.24. I was able to pin down the cause to the - Hide Top Bar Gnome Extension After disabling the extension fullscreen works again.

If you are using this or a similar extension, try disabling it for now.


Digging further I found the problem related to animations in gnome-shell ui packages (clutter?). The bug only appeared if the application window (chrome, shotwell) was already maximized before going fullscreen.

The freeze occured when entering fullscreen as well as leaving fullscreen:

  1. Full screen any application -> Freeze -> Alt+F2 -> r (Video runs in fullscreen)

  2. Exit full screen -> Freeze -> Alt+F2 -> r (Back to desktop)

By disabling animations (tweener) in Hide Top Bar Source panelVisibilityManager.js I was able to make 2. work again. 1. is related to Hide Top Bar removing and adding the PanelBox. I did not find a fast workaround that would also autohide the topbar.

| improve this answer | | | | |
  • That's it! I confirmed this exact behavior here. It is strange that after disabling the extension, there are still a hue change to bluish during the full screen toggle. For now I prefer not use fullscreen on Chrome, since I value more the extra space for work which I gain hiding the top bar. I have also reported this issue here in bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1681822 – chrisandrew.cl Apr 11 '17 at 12:24
0

I'm using Unity but hope this will work in gnome too.

There is 2 ways to half-solving this problem :

1st - is to disable hardware acceleration in Chrome, but this will decrease performance. (blurry scrolling and vertical lines)

2nd - Open videos in Firefox

If anyone has a better solution please post here. Tx a lot.

| improve this answer | | | | |
  • Unfortunately this seems to be a Gnome issue and it isn't occurring only when watching videos. Anyway, thank you for your collaboration! – chrisandrew.cl Apr 18 '17 at 14:33
0

As reported in https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1681822, updating Gnome Shell / Mutter to 3.24.1 fix this issue.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.