1

In spite of having enabled my weather indicator on the list of the Startup Applications, it never starts on startup; I have to do it manually all the time.

The command I entered is:

my-weather-indicator 

What am I doing wrong?

  • Hi Hilario, posted. Please mention if all is clear (or not). – Jacob Vlijm Apr 10 '17 at 15:48
  • Sorry I didn't know about that.It's done. – Hilario Ferreira Apr 10 '17 at 21:34
2

How to find out

I installed my-weather-indicator from its ppa: ppa:atareao/atareaoto find out. Its .desktop file in /usr/share/applications includes the line:

Exec=/opt/extras.ubuntu.com/my-weather-indicator/bin/my-weather-indicator

which indicates the command you need to run is:

/opt/extras.ubuntu.com/my-weather-indicator/bin/my-weather-indicator

You can see the content of the file by running the command:

cat /usr/share/applications/extras-my-weather-indicator.desktop

or:

gedit /usr/share/applications/extras-my-weather-indicator.desktop

Sometimes launchers (.desktop files) have multiple lines, starting with

To add it to Startup Applications

Choose Dash > Startup Applications > Add, and add the command

/opt/extras.ubuntu.com/my-weather-indicator/bin/my-weather-indicator

More information

The command you tried does not include the path to the executable:

my-weather-indicator

This only works if the executable is in $PATH. The application however is installed in:

/opt/extras.ubuntu.com/my-weather-indicator/bin

You can find out which directories are in $PATH by the command:

echo $PATH
1

A simple GUI based answer is,

  • Right-click on the indicator and select Preferences
  • In the Preferences window, click on General options and check the Autostart option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.