26

I want to install "Guest Addition" for my virtual Windows 7 but I don't see Devices menu. Why? enter image description here

9 Answers 9

17

I faced the same issue. You need to exit from scale mode (Right Ctrl + C). Then 'Devices' menu will appear.

2
  • 2
    Thank you! I thought I was going crazy.
    – Gaurav
    Commented Nov 19, 2019 at 22:57
  • Thanks from me as well, I was also very confused as to why I did not see it. Commented Mar 13, 2020 at 22:25
10

The Devices-menu to install Guest Additions will only be available after the virtual machine was started, is running, and the guest windows has focus.

3
  • 3
    There is no Devices menu even I start the Win7 machine, so I asked this question here. Commented Dec 25, 2011 at 17:39
  • The screenshot you included does not show any VM running. In fact it shows the menu from VBox Manager and not the menu you get when a running virtual guest windows has focus. That's why I felt you may need this answer. If I am wrong here then please edit your question to clarify this important detail.
    – Takkat
    Commented Dec 26, 2011 at 0:17
  • what does it mean - "the guest windows has focus"?
    – Viesturs
    Commented Mar 4, 2020 at 13:37
7

You can activate 'Devices' menu via View -> Menu Bar -> Menu Bar Settings.

2
  • This exactly! My menu bar simply wasn't showing that option. Commented Jan 22, 2016 at 21:30
  • YOU MY FRIEND, ARE MY SAVIOR. I don't think I deactivated it, so...
    – codenoob
    Commented Apr 1, 2020 at 23:05
6

Did you install the OSE from the repositories? The Guest Addons are proprietary and are not included in the OSE version of VB. You can download the guest addons ISO separately and install them that way.

2
  • This is not so. Only the Oracle extensions needed for RDP and USB2.0 support are closed source. Guest Additions are also included in the OSE edition. See also askubuntu.com/a/22745/3940
    – Takkat
    Commented Dec 25, 2011 at 12:25
  • As for Guest Additions there is a transitional package virtualbox-ose-guest-utils for the OSE edition in the repositories.
    – Takkat
    Commented Dec 25, 2011 at 17:07
2

I faced the same issue with MAC host and Ubuntu guest. Finally, I found this:

  1. Go to preferences.

  2. Select input → Virtual Machine

  3. Add shortcut key to Menu Bar Settings (I added HOST key + M)

    VirtualBox - Input dialog

  4. Click OK and go to running virtual machine and press the key combination for Menu Bar Settings. Then you can see the menu at the top of the screen

    dropdown menus in window

3
  • Welcome to askubuntu! Can you explain to us how this strategy will cause the Devices menu to appear? (or did you misunderstand the question)
    – Elder Geek
    Commented Sep 28, 2016 at 20:12
  • @ElderGeek, Thanks! Sorry, I did not understand this in your comment "did you misunderstand the question". I just did this to enable "Device Menu" of running virtual machine. Commented Sep 29, 2016 at 6:32
  • If that is indeed the case please edit your question to explain how your approach enables the Device Menu in Virtualbox running on Ubuntu
    – Elder Geek
    Commented Sep 29, 2016 at 14:16
1

I suppose you want to activate the shared folders.

It's easy:

  1. Start your virtual machine
  2. Select "Mount CD/DVD-ROM" from the "Devices" menu in the virtual machine's menu bar and then "CD/DVD-ROM image".
  3. In the Virtual Media Manager, press the "Add" button and browse your host file system for the VBoxGuestAdditions.iso file: On a Linux host, you can find this file in the additions folder under where you installed VirtualBox (normally /opt/VirtualBox/). to me: "/usr/share/virtualbox/"
  4. Back in the Virtual Media Manager, select that ISO file and press the "Select" button. This will mount the ISO file and present it to your Windows guest as a CD-ROM.
  5. Now open My PC from Windows
  6. There open de CD/DVD mounted: "VirtualBox Guest Additions"
  7. Open "VBoxWindowsAdditions-.exe", my pc is 32x so open: VBoxWindowsAdditions-x86.exe, if you need rights click Yes.
  8. click next
  9. click next or change the path
  10. Select Direct 3D support (optional) and Click Install
  11. Wait and click Finish and reboot your virtual machine
1
  • There is no Devices menu
    – Jonathan
    Commented Mar 24, 2015 at 1:21
1

Just go to user interface in Machine settings and mark devices so devices background become gray then restart your Machine and you will see Devices on the Menu bar.

Works for all options you need to see on Menu bar.

enter image description here

1
  • This answer worked for me eventually but this may help find the checkbox you need in VirtualBox 6.1: -Open Oracle VM VirtualBox 6.1 Manager -Select your machine -Settings -User Interface -Click on Devices button -Show at Top of Screen -OK -Start
    – Aethelbald
    Commented Mar 4, 2020 at 10:24
0

This works if your host machine is Ubuntu 11.10:-

When your virtual machine is running and is the active/focused window. Look to the top left of your screen, it should show "VirtualBox".

Move your mouse over the x in "VirtualBox", then you should see the Devices menu.

1
  • Looking at the image shows that this is not the case.
    – astex
    Commented Nov 5, 2012 at 17:08
0

On the guest machine monitor right click on the menu bar. Select Menu Bar Settings. Only the options that are there in your menu bar will be highlighted. You would find Devices option un-highlighted.

Screenshot.

Select it and press the green check button at the right end of the bar. The devices option should appear. This worked for me in VirtualBox version 5.1.26.

1
  • This doesnt' work in gnome. there is no menu bar settings
    – chovy
    Commented Nov 20, 2019 at 19:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .