1

I have a single OS install with Ubuntu 14.04.2 LTS on a digital kiosk, with no keyboard attached.

The kiosk reboot every night, but sometimes - rarely but it happends - the grub menu shows up, asking with no timeout to choose between :

  • Ubuntu
  • Advanced option for Ubuntu
  • Memory test (memtest86+)
  • Memory test (memtest86=, serial console 115200)

The only solution to boot the kiosk is then to attach a keyboard and press enter. There is my grub config :

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0 
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10 
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

How can I totally prevent grub menu from showing up and force Ubuntu to boot ?

What could explain that the grub menu is shown from time to time ?

  • Possible duplicate of How do I hide the GRUB menu showing up in the beginning of boot? – Ravexina Apr 10 '17 at 9:55
  • I already read this question very thoroughly, and it did not help. The key question is why from time to time. I think I know about obvious grub parameter, but I need some deeper insight. I thought about a physical memory issue ? Could that force a grub menu ? – Gabriel Glenn Apr 10 '17 at 10:43
  • I'm not sure what is the cause of this issue, have you consider using something like lilo? I think it'll fit your situation, +1 for more luck. – Ravexina Apr 10 '17 at 11:56
  • 1
    Grub has a parameter that forces menu to appear on abnormal shutdown. That is so you can decide if you need to boot in recovery mode to make repairs or not. help.ubuntu.com/community/Grub2 See entry on GRUB_RECORDFAIL_TIMEOUT settings in grub. – oldfred Apr 10 '17 at 16:55
  • @oldfred cool option, great hint. – Ravexina Apr 10 '17 at 21:17
3

Grub has a parameter that forces menu to appear on abnormal shutdown. That is so you can decide if you need to boot in recovery mode to make repairs or not.

https://help.ubuntu.com/community/Grub2

See section on Last Boot Failed or Boot into Recovery Mode. And See entry on GRUB_RECORDFAIL_TIMEOUT settings in grub and other info if grub entry does not work.

sudo nano /etc/default/grub

GRUB_RECORDFAIL_TIMEOUT=0

You may still need a Ubuntu live installer to run fsck or make other fixes as abnormal shutdown can cause issues that need fixes.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.