1

I updated graphics drivers today, which unfortunately causes a black screen at login. I want to access my desktop so I can copy certain files off the laptop while I figure out a fix, but I'm unable to open a terminal at login using Ctrl+Alt+F1.

Booting in recovery mode, I can select the "root" option to drop to a root shell prompt. From here, I can login to my user account through:

su --login myuser

...where I get a message that says "No directory, logging in with HOME=/". However, I cannot change directories to my Desktop, which should be located at /home/myuser/Desktop/. I can cd into the home directory, but it appears like there's nothing in it. Any thoughts on how to access my Desktop through the root shell?

  • It's <Ctrl>+<Alt>+<F1>... don't use <Shift>. – WinEunuuchs2Unix Apr 10 '17 at 0:19
  • Right sorry, that was a typo. I have been using Ctrl+Alt+F1 – Pat Tamburo Apr 10 '17 at 0:25
1

As I know, when you boot into recovery mode, the home partition will not mount automatically.

First locate your home partition using commands like: lsblk or fdisk -l or even by having a look at /etc/fstab:

# grep '/home' /etc/fstab | grep ext

Then mount that partition at /home (in my case sda2 is my home partition).

# mount /dev/sda2 /home

And copy your file to your desired path, device.

Remember that you may need to remount or mount your partitions with rw option.

  • 1
    If /home has a valid /etc/fstab entry it should be sufficient to type mount /home (or alternatively just mount -a) – steeldriver Apr 10 '17 at 11:13
  • That would do the work too ;) – Ravexina Apr 10 '17 at 11:15
  • Thanks for your help! For me, I ran the following commands to mount the home directory: mount --options remount,rw / mount --all This allowed me to access my files as I'm used to. – Pat Tamburo Apr 10 '17 at 13:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.