2

I've just bought a new laptop Acer Aspire E5-575-584A with only one SSD and its comes with an Acer Linux distribution. I installed Lubuntu 16.04 fine, but when I installed Ubuntu GNOME 16.04.02 something happened. Finally I installed Ubuntu 14.04 and the error is still the same.

I am new to this and I'm confused about the UEFI-Legacy installation. I've tried a lot of things but nothing works. My laptop cannot boot from ssd, only from a Liveusb/cd. But when I try for a new installation it seems that the ssd has the Ubuntu 14.04. I've got this message when I open it and I cannot find an answer on the web :

Failed to open \EFI\Microsoft\Boot\max64.efi - Not Found  
Failed to load image \EFI\Microsoft\Boot\max64.efi - Not Found
Failed to star MokManager : Not Found
Failed to open \EFI\Microsoft\Boot\grub64x.efi - Not Found 
Failed to load image \EFI\Microsoft\Boot\grubx64.efi : Not Found
start_image() returned Not Found

AND afters one-two seconds the message becomes:

Failed to open \EFI\Boot\max64.efi - Not Found  
Failed to load image \EFI\Boot\max64.efi - Not Found
Failed to star MokManager : Not Found
Failed to open \EFI\Boot\grub64x.efi - Not Found 
Failed to load image \EFI\Boot\grubx64.efi : Not Found
start_image() returned Not Found

This is my Boot Repair log

3 Answers 3

3

Your computer uses EFI firmware, and the Boot Repair output looks like the computer came with a Windows installation that you deleted and replaced with Ubuntu. I know you say it came with "an Acer Linux distribution," which is why I'm leading with what your Boot Repair output suggests, since the two are at odds. My suspicion is that, for whatever reason (maybe a defective firmware), Acer installed their Linux boot loader in a way that makes it look like the Windows boot loader, and the computer is still trying to boot via that boot loader. Other changes must have deleted follow-up boot loader programs, resulting in the error messages you're seeing.

I can think of several ways to fix this problem, but none of them is guaranteed to work, so you may need to try multiple approaches. I'll describe a couple that are most likely to work....

Method 1: Boot Repair

  1. Boot your Ubuntu installation medium in "try before installing" mode.
  2. Launch Boot Repair.
  3. Click the Advanced Options item.
  4. Select the "Backup and Rename Windows EFI Files" option.
  5. Click Apply to run Boot Repair.

Method 2: rEFInd

  1. Download the CD-R or USB flash drive version of my rEFInd boot manager from the links here.
  2. Create a medium using the image you downloaded.
  3. Boot into your firmware setup utility and disable Secure Boot. Unfortunately, how you do this varies from one system to another. See this page of mine for several examples of how to do it.
  4. Boot with the rEFInd medium.
  5. In rEFInd, select a Linux kernel image (Boot boot\vmlinuz...) to boot your current Ubuntu installation.
  6. Install rEFInd by using the Debian package or PPA.
  7. Reboot. If rEFInd comes up, you should be able to boot Ubuntu and you'll be good. If not....
  8. Boot with the rEFInd medium you prepared earlier, and boot to Ubuntu, as in step #5.
  9. Open a terminal and type sudo mvrefind /boot/efi/EFI/ubuntu /boot/efi/EFI/Microsoft/Boot.
  10. Reboot. With any luck, rEFInd will appear.

You may optionally re-enable Secure Boot, and you may want to delete redundant boot loader files from /boot/efi/EFI/*/ directories or edit refind.conf in /boot/efi/EFI/refind/ or /boot/efi/EFI/Microsoft/Boot to uncomment and add boot loaders to the dont_scan_dirs or dont_scan_files lines.

0

It happened to me when trying to boot from live USB with Ubuntu LTS 18.10 on a Huawei Matebook Pro.

What worked for me is to just disable secure boot on bios.

0

I've had the same issue after burning elementary os 6 to a USB using etcher , then booting from the flash drive i was prompted with this error .
My bios settings include
-secure boot enabled
-legacy mode disabled
My workaround was
-power on the PC
-press a function key -ESC in my case- to enter startup menu
-Run UEFI Application
-Choose the portable drive to boot from e.g. USB:Kingston DataTraveler
-File browser : EFI / Boot > BOOT > GRUVBOX64.EFI

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .