My Panda USB wi-fi adapter works just fine on 16.10, but when I try to connect to my wi-fi router in 17.04, GNOME network manager reports "Connection failed." I did some tinkering, and noticed that my MAC address for my wifi adapter, according to GNOME, is DIFFERENT every time I make it forget my wifi settings and try to reconnect. Any leads on a possible fix or work-around?

I'm running Ubuntu GNOME 17.04, kernel 4.10.0-19-generic, GNOME 3.24.0.

  • I also filed a bug for this issue: bugs.launchpad.net/ubuntu-gnome/+bug/1681513 – Jesse Apr 13 '17 at 21:07
  • @Jesse when you say " [device] wifi.scan-rand-mac-address=no" does one change [device] to the specific wireless device, or leave it literally "[device]"? Maybe you can let us take a look at your NetworkManager.conf file. – heynnema Apr 13 '17 at 21:53
  • @heynnema, it's left as "[device]", just like that. You don't need to change it to the actual device. Then, on the next line, past the text "wifi.scan-rand-mac-address=no". – Jesse Apr 13 '17 at 21:58
  • 1
    @Jesse I think we will need some further info to get a firm grasp on what your situation is. In most cases everything needed can be obtained via the wireless script available here Thank you for helping us help you! – Elder Geek Apr 13 '17 at 22:19
  • 1
    For those who don't understand the reason behind mac randomisation during scanning, arstechnica.com/apple/2014/06/… might be informative. – unhammer Apr 16 '17 at 19:02
up vote 104 down vote accepted

So Jesse discovered a solution and I'm going to share it here in answer form as clearly as I can muster. This fixed wifi for me using a Panda Wireless USB wifi adapter on Ubuntu 17.04:

For privacy reasons, the default settings for Ubuntu 17.04's network manager (ALL flavours, not just GNOME) cause the MAC address of the Wifi device to change constantly. To fix this, you just have to create a new config file as outlined below and then restart the network-manager service.

Open a terminal and run:

sudo tee /etc/NetworkManager/conf.d/wifi.scan-rand-mac-address.conf > /dev/null <<EOF
[device]
wifi.scan-rand-mac-address=no
EOF
sudo service network-manager restart

and wifi should work again! (unless something else is wrong).

This fix should work even on a live CD/USB session.

  • 1
    That is great, man! – heroin Apr 15 '17 at 15:54
  • 3
    Why isn't this ironed out in betas? This is so unprofessional, to release a distro with such high importance bug – Hrvoje T Apr 15 '17 at 22:14
  • 12
    @HrvojeT: Did you help with beta testing? – Gunnar Hjalmarsson Apr 16 '17 at 20:28
  • 3
    I had the same problem. Did what you described but it is not working – Jay Chakra Apr 20 '17 at 0:07
  • 3
    After fixing this issue I also had to do what's described here to get online: superuser.com/a/1200745/722957 – Matt Apr 28 '17 at 6:01

protected by Community Apr 16 '17 at 7:12

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.