26

I'm trying to add a VPN to my network, but the option is greyed out.

Screenshot of the greyed-out indicator

I installed network-manager-openvpn but still no luck. Editing my connection does not show any VPN settings or tabs.

I'd appreciate it if anyone could point me in the right direction!

EDIT: In case anyone else has this issue, the wording "Add A VPN Connection" is super misleading as it's telling you that you need to add a VPN connection, not that you are supposed to click to add one from there.

So select Edit Connections, Add, and then select your VPN from there.

  • 1
    Can you add one from Settings -- > Network and clicking the + icon? – Android Dev Oct 23 '16 at 19:45
  • @AndroidDev Yes that works fine! – Håkon Hægland Oct 23 '16 at 19:52
  • Does anyone have clues why the entry shown in the image is disabled? – naktinis Nov 14 '16 at 1:04
  • still greyed out? Same with "configure vpn" after having added a connection. – Christian Nov 28 '16 at 14:08
  • Did you install network-manager-openvpn ? – Harmonic Aug 11 '17 at 17:57
47

In case anyone else has this issue, the wording "Add A VPN Connection" is super misleading as it's telling you that you need to add a VPN connection, not that you are supposed to click to add one from there.

So select Edit Connections, Add, and then select your VPN from there.

  • 6
    Wow ... I consider myself a "power-user" but this had me googling for a while. Thank you! – grongor May 5 '17 at 9:16
  • 2
    No amount of intelligence can save you from bad UI design – Nick T May 24 '18 at 5:18
9

I recently set up VPN on Xubuntu 16.04 LTS for the first time. This is what I had to do:

sudo apt install openvpn
sudo apt install network-manager-openvpn-gnome 

I used network-manager-openvpn-gnome instead of network-manager-openvpn to get the option to import the VPN configuration files.

After that I could go to:

  1. Edit Connections at the bottom of the menu
  2. Click on the Add button on the next window
  3. Choose Connection type
  4. Import a saved VPN configuration

After that I was able to edit the VPN connection by

  1. Edit Connections... at the bottom of the menu
  2. Select the VPN connection I want to edit
  3. Click on the Edit button

  • Thanks, but I actually answered my own question before you posted :) Upvote because your answer will help anyone else who finds this page. Thanks! – Harmonic Apr 11 '17 at 19:17
2

The easy way is using a command on terminal:

nm-connection-editor

nm-applet normally starts at login by the desktop session manager and does not need to be run manually.

In some versions of Ubuntu there were problems in the security policy.

To solve this you should edit the file 'org.freedesktop.NetworkManager.policy' on /usr/share/polkit-1/actions/

sudo -H gedit /usr/share/polkit-1/actions/org.freedesktop.NetworkManager.policy

And change this action:

<action id="org.freedesktop.NetworkManager.settings.modify.own">
.
.
.
<allow_inactive>no</allow_inactive>

to

<allow_inactive>yes</allow_inactive>

Then restart network-manager

sudo systemctl restart network-manager

protected by Community Apr 14 '18 at 23:31

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.