I use Ubuntu 16.04.2. I installed xrdp and xfce4 according to this page. It was OK and I ran some program remotely.

Then I installed some programs on the system such as CUDA 8.0, Oracle Java, openssh, vsftpd...

But now I cannot open installed program in remote session. For example when I run Nautilus a window appears and says:

Failed to execute default File Maneger.
Input/Output Error.

I tried to run nautilus via terminal but it failed and the following error massage appeared:

Segmentation fault (core dumped)

I also tried to run Firefox via terminal:

$ /usr/bin/firefox
ExceptionHandler::GenerateDump cloned child 26648 ExceptionHandler::SendContinueSignalToChild sent continue signal to child ExceptionHandler::WaitForContinueSignal waiting for continue signal... Segmentation fault (core dumped)

I tried MATE desktop, but the problem recurred.

Any help would be appreciated.


The problem resolved!

As I mentioned, I have installed CUDA 8. I used CUDA .deb file to install it. During installation many additional package were installed. One of them was openjdk. After installation I removed openjdk and installed Oracle JDK. As a result CUDA 8 and its dependencies went to apt autoremove!

When I frustrated, I do apt autoremove, and magically remote session problem resolved! Then I install CUDA 8 using its .run file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.