6

The default version of FileZilla available in Ubuntu Software is 3.15.something, while the actual latest version of FileZilla is 3.25.1.

I'm trying to get 3.25.1 installed from GetDeb, but it's giving me 3.21 instead.

On the GetDeb FileZilla page, it says 3.25.1 is only available for Ubuntu 16.10, which doesn't make any sense.

How can I get FileZilla 3.25.1 installed on Ubuntu 16.04? (preferably from GetDeb or some other PPA so that it can be easily updated in the future)

1

There are two parts to your question.

1. Why is GetDeb only installing FileZilla 3.21.0-1~getdeb1?

Because that is the only version available in the GetDeb repo for Ubuntu 16.04

GetDeb Filezilla

2. How can I install FileZilla 3.25.1?

The instructions are available from the official wiki

Method #1:

Get the install script from here

Or save the following to a file (this is taken directly from the paste for convenience, however I did not write it. Credit goes to Josh Lear):

#!/bin/s
#------------------------------
#Author: Josh Lear
#Email: jlear2013@my.fit.edu
#Last update: December 10, 2014
#Basic script for beginners
#to get filezilla on most 
#linux distributions
#------------------------------
apt-get install subversion #get subversion
svn co https://svn.filezilla-project.org/svn/FileZilla3/trunk filezilla #get filezilla source
apt-get install libgnutls-dev #install libgnutls
apt-get install libidn2-0-dev #install libidn
apt-get install gettext #install gettext
apt-get install libdbus-c++-dev #install libdbus
apt-get install libwxgtk3.0-dev #install wxWidgets
apt-get install libperl-dev #install libperl-dev
apt-get install libtool #install libtool
apt-get install autoconf #install autoconf
apt-get install automake #install automake
autoreconf -i #generate a configuration per system settings 
./configure #configure the filezilla distro 
make #make filezilla
make install #install filezilla

Execute the file as root to install.

Method #2

Essentially they are as follows:

sudo apt-get install gettext autoconf automake libdbus-c++-dev libperl-dev libtool libgtk2.0-dev libsqlite3-dev libtinyxml-dev libdbus-1-dev

Download the SourceCode from the official links

Extract the code and run the following within the extracted folder:

sudo ./configure
sudo make
sudo make install
| improve this answer | |
  • Seems odd that 3.25.1 is limited to the 16.10 repo. Could I just use the 16.10 repo even though I'm on 16.04? I have no problem installing it manually, but would prefer to use a repo in order to easily get future updates. – Mixx Apr 9 '17 at 2:37
  • I cannot answer why it's only available for 16.10. That's something you'd have to take up with the GetDeb crowd. Using the 16.10 repo may be possible, but I'd be extremely wary of dependencies. – ThatGuy Apr 9 '17 at 2:49
  • Method #1: maybe you forgot "cd filezilla" before autoreconf? Also got an error "configure: error: libfilezilla not found: No package 'libfilezilla' found. You can download it from lib.filezilla-project.org" – d9k Nov 16 '17 at 15:53
  • On filezilla v. 3.29.0 src: "checking for wxWidgets version >= 3.0.3 (--unicode=yes --universal=no)... no (version 3.0.2 is not new enough)" – d9k Nov 16 '17 at 16:16
  • So how to update to desired source version using svn? Upd: got it: filezilla-project.org/sourcecode.php – d9k Nov 16 '17 at 16:30
0

When I asked this question to the GetDeb admins, I was told that there was a dependency on libgnutls28-dev (>= 3.4.15) for the latest FileZilla. There is only version 3.4.10-4ubuntu1.2 in Ubuntu 16.04. This is why it fails to build there.

| improve this answer | |
0

I know you asked for a ppa, but if you download the linux version from the official page you only need to extract it to your preferred folder. And when a new version is published, you only need to delete the old folder and extract the new one.

And if you want it to be "installed" add a symlink in /usr/bin with:

sudo ln -s /home/PhoneixS/Programs/FileZilla3/bin/filezilla /usr/bin/filezilla

I think this is easier than compiling from source (but I recognized that is harder than using a ppa).

| improve this answer | |
  • 1
    thx, but got an error: "filezilla: error while loading shared libraries: libpng16.so.16: cannot open shared object file: No such file or directory" – d9k Nov 16 '17 at 15:59
  • @d9k has you tried to install it? For example sudo apt install libpng16-16 – PhoneixS Nov 16 '17 at 21:18
  • libpng16-16 installed ok, but now we get ./filezilla: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version GLIBCXX_3.4.22' not found (required by ./filezilla). So much for extracting and running. Why isn't there a PPA available with current versions. – a coder Feb 12 '18 at 18:45
  • @acoder see askubuntu.com/questions/575505/… – PhoneixS Feb 13 '18 at 9:05
  • Tried the selected answer: libstdc++6 is already the newest version (5.4.0-6ubuntu1~16.04.6). – a coder Feb 13 '18 at 18:43
0

download latest from its official page. Once downloaded extract filezilla3 folder will appear in my case this is the path /home/user/FileZilla3. open FileZilla3 their two folders "bin", "share" open bin folder their is application named filezilla click on it and enjoy.

| improve this answer | |
  • Does not work for me, I get the message "Could not display 'filezilla'. There is no application installed for 'shared library" files." – Rob Stoecklein Oct 24 '17 at 15:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.