16

How can I register an .appimage file (specifically, the tiled map editor found here) as a desktop app? (Like firefox -- I can launch it by typing 'Firefox' into search rather than opening up a console and typing /path/to/directory/firefox.ext)

  • Place the executable file in you PATH in say /usr/bin and you should be able to launch it like firefox... – George Udosen Apr 8 '17 at 23:51
  • Is there a way to put a 'shortcut' to the file in my PATH? I don't want to move it there. – Matias K Apr 8 '17 at 23:53
  • Never mind, I just made a bash script that launches it and stuck that in ~/bin. Thanks for your help, even though you didn't actually answer the question :P – Matias K Apr 8 '17 at 23:54
4

You can also use AppImageLauncher which provides desktop integration along with some additional features. Unlike appimaged, it:

  • asks for confirmation before creating desktop entry for an AppImage.
  • works with AppImages in any location
  • doesn't use a daemon for monitoring, so more efficient.

Specifics of how it works are explained in the wiki. It can be installed directly from the packages provided in the releases.

8

According to appimagekit, the proper method is to use appimaged for .AppImage file registration.

For 64-bit systems:

wget "https://github.com/AppImage/appimaged/releases/download/continuous/appimaged-x86_64.AppImage"
chmod +x appimaged-x86_64.AppImage
./appimaged-x86_64.AppImage --install

The binary will copy itself to /home/ubuntu/.local/bin/appimaged and then delete the downloaded copy upon install. Then you must logout and back in.

At time of reading, it will monitor and register the following locations:

~/Downloads
~/.local/bin
~/bin
/Applications
/isodevice/Applications
/isofrom/Applications
/run/archiso/img_dev/Applications
/opt
/usr/local/bin

To show in the menu, this assumes you've placed a desktop file in the correct location inside your .AppImage file, usually /usr/share/applications/<myproject>.desktop.

If you search in the application tray, you should find your application shortly. The daemon should also register any application-specific file associations assuming the mime xml is also bundled, usually /usr/share/mime/packages/<myproject>.xml. If the icon does not appear correctly, you may have to logout and back in a second time. This can happen if the icon was incorrectly cached while testing out images.

  • The advice at appimaged link says to enable with sudo systemctl --user [...], but shouldn't it be --system [ie default], won't --user mean that it only enables for my user. I'm trying to install digikam for all users, FWIW. – pbhj Dec 19 '17 at 23:58
  • On my system, Ubuntu 14.04, the systemctl steps did not work properly. You should ask the project team how best to do this. The service seems like it's intended to be run in user-space by design, so the system-wide installation technique does not seem to be obvious. Perhaps you would be happy with the appimage located permanently somewhere (e.g. /opt/bin/appimaged with a login script for all users in /etc/xdg/autostart/appimaged.desktop, but one which uses the --no-install switch. – tresf Dec 26 '17 at 17:26
  • Then place digicam in (e.g.) /opt/bin/digicam and the daemon should find it as it will match the second-to-last search location mentioned above. – tresf Dec 26 '17 at 17:28
8

Create a .desktop file that points to the application -- here is an example of a .desktop for minecraft:

[Desktop Entry]
Type=Application
Name=Minecraft
Comment=Minecraft
Icon=/home/bram/Applications/Minecraft/icon.png
Exec=/home/bram/Applications/Minecraft/minecraft
Terminal=false
Categories=Minecraft;game

Put that file in ~/.local/share/applications

  • Done what you said, It will keep open a terminal while I am executing the AppImage? Is there a way to just open the AppImage without a terminal together? – Cassiano Montanari Dec 27 '18 at 17:35
  • 2
    Why would you need to download a separate icon when the appimage includes one? How can you use the icon from the appimage itself? – Dan Dascalescu Feb 3 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.