2

I don't get my USB WiFi working. The TP-Link Archer T9UH is using the Realtek RTL8814AU chip set. Found here. The driver link on this side points to a driver which is only for older kernels < 4.4.

Searching around I found some drivers for this chip set. The last one I tried is this one.

The installation of the modules works lsmod shows it with usage 0. lsusb shows

Bus 003 Device 003: ID 2357:0106 

Any ideas to get the WiFi working?

  • I suggest that you try @Pilot6 's answer here: askubuntu.com/questions/879187/asus-usb-ac68-0b051817-drivers/… – chili555 Apr 8 '17 at 20:04
  • With this I get the following from dmesg [ 1348.317361] 8814au: loading out-of-tree module taints kernel. [ 1348.318100] 8814au: module verification failed: signature and/or required key missing - tainting kernel - but no WiFi – Rüdiger Gubler Apr 8 '17 at 20:11
  • After reboot and manual modprobe I got the following in dmesg: [ 110.968228] 8814au: loading out-of-tree module taints kernel. [ 110.968686] 8814au: module verification failed: signature and/or required key missing - tainting kernel [ 110.970796] RTL871X: module init start [ 110.970797] RTL871X: rtl8814au v4.3.21_17997.20160531 [ 110.970823] usbcore: registered new interface driver rtl8814au [ 110.970824] RTL871X: module init ret=0 but still no WiFi – Rüdiger Gubler Apr 8 '17 at 20:18
  • Let's see: dmesg | grep -e 8814 -e RTL and also:rfkill list all and also:iwconfig – chili555 Apr 8 '17 at 20:47
  • This fork ist the solution: github.com/ScrambledAuroras/rtl8814AU/commit/… It will add the device id. – Rüdiger Gubler Apr 8 '17 at 20:55
2

This fork is the solution - it will add the TP-Link device id. After install the module I needed to insert the 8814au in /etc/modules to get the module loaded at boot time.

  • Can give some feedback on how well this device performs on Linux or Windows? MTR logs from full load on wifi for some time or something? Device is quite expensive and 5GHz adapters are few on Linux I hope you can share this info you're one of the only mentions on Google using this adapter in Linux :) Thanks! – dezza May 18 '17 at 6:52
  • Using github.com/sbosshardt/rtl8814AU worked for me. The fork referred to in the answer was merged into here at some point. – libcthorne Sep 30 '17 at 14:47
  • We are using using this device with Linux. The performance is exellent. – Rüdiger Gubler Oct 3 '17 at 16:43
  • 1
    I had to get zebulon2's fork to get it to compile on Linux 4.13. – z0r Apr 11 '18 at 4:07
1

This fork: https://github.com/mathew19/rtl8814AU, will work with the latest 17.10 kernel

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.